Problem with PGI compiler


when i’m compiling CAMx using PGI compiler. I am getting the following error.
pgf90-Error-Unknown switch: -mcmodel=medium
make[1]: *** [Mod_src/camx_includes.o] Error 1
make[1]: Leaving directory `/home/cese/mayank/camx’
make: *** [pg_linux] Error 2

I am new user to pgi and CAMx.can anyone tell me the solution.Any help would be highly helpful.
I am using fedora13 and Intel i3 processor

with regard


Can you compile just a helloworld program? If yes, add a flag -mcmodel=medium. If no, I wonder if the installation is complete.


Thank you very much Hongyon for your reply. I have successfully compiled and run helloworld program. As I told I am totally new to this enviroment. Can you please tell me how to add flags in pgi compiler. Using terminal in fedora 13

Hi Mayank,

My best guess is that your using the 32-bit compilers. “-mcmodel=medium” is a 64-bit only flag. What is the output of “pgfortran -V”?

If this is case then your options are to set your PATH environment variable to use the 64-bit compilers, or change CAMx’s Makefile link so that it points to the 32-bit Makefile, “Makefile.32bit” instead of the default 64-bit Makefile, “Makefile.pg_64bit”.

Hope this helps,