problem with Quadro P1000

Probably not at all. I think you’re suffering from this unsolved kernel bug:
https://bugzilla.kernel.org/show_bug.cgi?id=156341
The acpi_osi settings are a common workaround for most but not all affected machines. Please run

sudo acpidump >acpidump.txt

and attach the output file, maybe a different workaround can be found though chances are low.
To get a working system, you’d have to uninstall bbswitch so that the nvidia gpu doesn’t get turned off.

I attached the acpidump via

acpidump -v -d -f acpidump.txt

I will report at DELL. I did not hear any issues from ubuntu users but could be that noone is using bbswitch anymore.

Can I safely try to switch to pure nvidia-driver and remove bb even if my

lsmod | grep nvidia

does not show anything? I work reliably on intel graphics right now, but I would love to be able to switch.

acpidump.txt (1.66 MB)

bbswitch is only needed in order to save power, so without it you can still use bumblebee. The downside is increased power consumption (~2-3W)
In general, due this bug the nvidia gpu will also be inaccessible after a suspend/resume cycle since it can’t be turned on again regardless of bbswitch.

I have tried without bbswitch and xserver is not starting.
Xorg.1.log (46.4 KB)
kern.log (1.49 MB)

bbswitch is still loading and turning off the gpu.
Try blacklisting it, create /etc/modprobe.d/blacklist-bbswitch.conf with contents

blacklist bbswitch

then run

sudo update-initramfs -u

and reboot.

I came up with another solution which seems to work:

There is a setting that controls the power management of bbswitch in

/etc/bumblebee/bumblebee.conf
[driver-nvidia]
PMMethod=auto

I have switched to

PMMethod=none

and that keeps the gpu enabled. Feels like the easiest solution.

With that, I am permanently running on the nvidia graphics which should be fine right now.

optirun glxgears -info                
GL_RENDERER   = Quadro P1000/PCIe/SSE2
GL_VERSION    = 4.6.0 NVIDIA 418.74
GL_VENDOR     = NVIDIA Corporation
GL_EXTENSIONS =

I also have the

acpi_osi=Linux

kernel parameters but I don’t think it is needed here as PM is now disabled anyway.