Problem with Quadro P4000 in DELL Precision Tower 5810 as non root user

Hello. We bought some DELL Precision Tower 5810 workstations to use as CUDA development machines. They have NVIDIA Corporation GP104GL [Quadro P4000] cards in them shipped from DELL.

These machines are running RHEL 7.

I have tried installing the driver from file as well as trying to use the distro pre-packaged drivers from “rpmfusion-nonfree” and “negativo17” and all of them give me the same error.

When I try to run opengl applications such as glxgears or glxspheres64 it opens a black window and the program hangs.

If I run the same program as the root user via “su -” it works fine. Disabling selinux by using permissive mode has no effect on this.

Any idea what is going on here? The same drivers on a GeForce GT 640 in my office works fine as a regular user. I have generated the nvidia-bug-report.log.gz on the problem machine.

Here is a link to the nvidia-bug-report.log.gz

Let me know if you have trouble accessing it?

Also, let me know if there is further information I can provide to try to determine how to fix this.

Sorry. This is a problem in my account’s $HOME directory. It turned out I had a .nvidia-settings-rc from 2014 and a .nv/ directory and after renaming these glxgears and glxspheres64 work now.

Sorry for the noise. :)