Problem with Rtabmap on xavier with melodic

Hi,

I’ve just switched to using a jetson xavier from the tx2 due to processing and ram restraints. Having installed the necessary software ie ROS and Rtabmap, The 3D map viewer window doesnt seem to want to work and consequently i’m unable to view the point cloud being built. Everything works perfectly fine on the tx2 running kinetic. This happens for both ros-rtabmap and standalone altohugh rviz works fine. Ive built rtabmap and rtabmap-ros from source although ROS is built from package.

Would anyone have any ideas how to overcome this, what may be causing it or what dependencies i’m overlooking.

thanks
Dan


Did you use the same BSP on TX2 and Xavier?
IF not could you verify on TX2 with r32 base.

I’m a little unsure what you’re asking. I’m fairly new to using Linux and have been teaching myself over the last 5 months. All I’ve done with both the tx2 and Xavier is install jetpacks 3.2 and 4.2.1 respectively. Then installed ROS and rtabmap from source to use with the zed cameras.

It could be your configuration not correct.
Please have a check the video node number is the same on TX2 and Xavier.

v4l2-ctl --list-devices

this the output $Failed to open /dev/video0: No such file or directory

Does this use case need camera?
Looks like someone got it worked.

https://devtalk.nvidia.com/default/topic/1039544/jetson-agx-xavier/rtab-map-on-agx-xavier-/

I do need a camera, as my project is handheld mapping using ZED cameras and lidar.

I have spoken to the original poster from the link and he stated he just uses rviz as his 3D window also doesnt work. It appears to be a problem from nvidias side and the associated jetpacks. This problem occurs with another person using a nano on the RTABMAP forum and the jetpack 3.3 for the TX2 hence me regressing back to JP 3.2 which works perfectly fine.

Hi,

ZED camera is enabled for Jetson platform from JetPack4.2:
https://www.stereolabs.com/blog/announcing-zed-sdk-for-jetson-nano/

Have you followed the instructions shared in this tutorial?
https://github.com/stereolabs/zed-ros-wrapper/tree/master/examples/zed_rtabmap_example

Thanks.

Hi,

Yes I am aware the zed camera is enabled, I have been using it on the Xavier.

I have followed the instructions. The problem isn’t running the zed camera with rtabmap or getting rtabmap_ros to run. It is the 3D map pane when using the software doesn’t work. This stops me or any other user in this situation from seeing the point cloud when using rtabmap and rtabmap_ros or viewing uploaded databases from multiple map scans.

Since jetpack 3.2 something has been changed or removed in newer jetpacks that for some reason impacts the use of rtabmaps 3D map window. See my attachments in my original post.

Thanks

Does 3D map have use ZED camera? If not it could be the rtabmap compatible on different ubuntu version and kernel version.

I don’t understand what you mean “does 3d map have use zed camera”? I have had to use rviz to get some form of visualisation working but in the field this is impractical for handheld mapping or revisualisation using database files post mapping to create multiple session maps.
The Ubuntu version and kernel version is basically my point from the beginning. But unlike other Jetsons we are unable to use a custom kernels on the Xavier by design, so I’m stuck between a rock and a hard place!

From your #5 looks like your system didn’t detect any cameras, and if your feature need camera that could be the root cause. Then you may need to debug why the system can’t detect this camera first.

That was my mistake I get ZED-M (usb-3610000.xhci-1.3): /dev/video0.

Someone else with the same problem.

Are Nvidia likely to create a working solution for this?

Does the link you posted didn’t a solution?

Unfortunately no. That was only a temporary fix for the nano and as noted in the thread it would also disable other necessary plugins. It really needs something from the Nvidia end that works for all jetpacks beyond 3.2. As this occurs on all the Jetson systems using jps 3.3 or 4.1+ running Ubuntu 18 and ROS melodic.

I did try to change the opencv as per jetsonhacks and jkjung but these still don’t solve the problem. And also the workaround on github is for the nano and not the xavier!

Any further feedback from nvidia?

same problem.
I’ll other feedback from nvidia, too…

I have exactly the same problem in Jetson TX2, with the realsense camera D435.