Problem with SDK Manager seeing multiple Nvidia devices

I’m having a problem installing my new Jetson AGX Xavier.
The installation process goes well until it tries to flash the Jetson. I connect the device and try the Manual Setup option (device is connected, I pressed Force Recovery + Power…) but I get an error which I couldn’t find mentioned anywhere else on the internet:
“Multiple Nvidia devices are connected. Please connect only one Jetson AGX Xavier device.”
Needless to say that there is no other Jetson connected to the host computer.

After a day or so of work, I think I maybe understand the source of the problem: the host computer has an “NVIDIA Stereo Contoller” that appears to be connected via USB (I don’t fully understand how this works, is it kind of “internal” USB connection? because nothing is connected from the outside).
This device (or is it a driver?) apparently interferes with the JetPack installer somehow.
The host computer is a laptop containing a GeForce GTX 780M internally, with Ubuntu 18.04 installed.
I tried changing drivers for the GeForce GTX 780M but this seems to do nothing. I also tried disabling the “hostile” device but with no success (not sure if this is a good idea at all).

Please, any advice will help. It’s been a tough week and I really want to have my Jetson finally installed so I can start the real stuff.

I’m not familiar with the stereo controller, but on the host, monitor “dmesg --follow”, and then connect the recovery mode Xavier. What messages show up?

Before you connect the Xavier, list all NVIDIA USB devices:

lsusb -d 0955:

After connecting the recovery mode Xavier, run that same lsusb again. What shows up which is new?

FYI, the 780M will have no effect on this and is unrelated. Determining what is connected is entirely over USB. PCI won’t even be examined (well, if you add CUDA to the host it will, but this isn’t what the “too many devices” issue is talking about).

Yeah, I already did those checks. This is indeed how I found the aforementioned “Stereo Controller”.
When I run lsusb -d 0955: before connecting the Jetson I see device with ID 0955:7002 which I googled and found to be the Stereo Controller. After the connection there are two Nvidia devices, the new one is the Jetson (0955:7019) but the two together somehow confuse the installer.
Any idea on how to solve? Maybe a command to force Ubuntu to disconnect the Stereo Controller? I don’t mind destroying it permanently: I only care about the Jetson installation.
Thank you

I’m not familiar with the stereo controller. Is this something which is intended to be flashed in a manner similar to the Jetson? If so, then I could see how it would confuse the flash software. If not, then this is probably a bug in the installer.

It is hard to say how to deal with that controller without knowing what it really is. It sounds like it isn’t something you’ve attached to a removable USB socket. More details.

Anyone from NVIDIA know what the stereo controller is with ID “0955:7002”? It isn’t listed in the standard device registry, so I’m guessing it is a less known product or something specialized.

Hi yoyo6158h,

I have no idea to handle the stereo controller, but I think you can use a workaround to solve the problem.

  1. Flash Jetson Xavier board manually.
    a. Put the Jetson Xavier board to recovery mode.
    b. Open a terminal, and if you haven’t changed the default installation directory, run following commands:
    cd ~/nvidia/nvidia_sdk/JetPack_4.2.1_EA_Linux_P2888/Linux_for_Tegra
    sudo ./ jetson-xavier mmcblk0p1
  2. After flashing, configure Language, timezone, locales, set up username and password, then let Jetson Xavier board continue to boot so you can see its desktop.
  3. Install Jetson SDKs with SDK Manager via Ethernet, instead of via usb cable.
    a. Connect ethernet cable to the Jetson board. Then check its IP address.
    b. Start SDK Manager. At STEP 02, uncheck “Jetson OS” to skip flashing. Then continue.
    c. When SDK Manager pops up a window for IP Address/Username/Password, do NOT use the default IP address, Instead, enter the IP address got from 3.a above. Also enter username and password of the Jetson device.
    d. Continue installation.

Thank you so much, @EdwardZhou. This finally solved it. After a week or so!