Problem with starting AIAA server [127.0.0.1 refused to connect]

Hi

I followed the instruction on how to install Clara Train SDK (https://docs.nvidia.com/clara/tlt-mi/clara-train-sdk-v2.0/nvmidl/installation.html), and AIAA (https://docs.nvidia.com/clara/tlt-mi/clara-train-sdk-v2.0/aiaa/quickstart.html)

I started to Docker on Ubuntu 18.04 (is it a problem as the requirements said 16.04) with

docker run --runtime=nvidia -it --rm -v /home/petteri/test_Niftis:/workspace/clara-experiments -e NVIDIA_VISIBLE_DEVICES=1 $dockerImage /bin/bash

And added ServerName local to apache2.conf to fix the using 172.17.0.2. Set the 'ServerName' directive globally to suppress this message warning

And tried to start AIAA with the default start_aas.sh

And had this coming:

start_aas.sh
/opt/nvidia/medical/aiaa-launch-config.json

ENGINE:: engine=TRTIS
TRTIS:: Backend is enabled

TRTIS:: trtis_ip=localhost
TRTIS:: Will setup TRTIS Server on localhost

TRTIS:: trtis_http_port=8000
TRTIS:: trtis_grpc_port=8001
TRTIS:: trtis_metrics_port=8002
TRTIS:: trtis_proto=grpc
TRTIS:: trtis_model_path=/var/nvidia/aiaa/trtis_models
TRTIS:: trtis_verbose=false
TRTIS:: trtis_log=/var/nvidia/aiaa/logs/host-80/trtis.log
TRTIS:: trtis_start_timeout=120
TRTIS:: trtis_model_timeout=30

TRTIS:: Waiting 1 seconds to fully up...
TRTIS:: Server started with pid: 4939

AIAA:: aiaa_port=80
AIAA:: aiaa_log_file=/var/nvidia/aiaa/logs/host-80/aiaa.log
AIAA:: aiaa_log_dir=/var/nvidia/aiaa/logs/host-80
AIAA:: aiaa_workspace=/var/nvidia/aiaa
AIAA:: aiaa_ssl=false
AIAA:: aiaa_ssl_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
AIAA:: aiaa_ssl_pkey_file=/etc/ssl/private/ssl-cert-snakeoil.key

 * Stopping Apache httpd web server apache2                                                                                                                                                        * 
Site 000-default already disabled
Site AIAA already disabled
Enabling site AIAA.
To activate the new configuration, you need to run:
<b>  service apache2 reload</b>
<b>Starting AIAA Server...</b>

And cannot connect to “http://127.0.0.1:5000/logs?lines=100 (127.0.0.1 refused to connect)

Is this a apache2 issue, as service apache2 reload returns this for example?

 * Reloading Apache httpd web server apache2                                                                                                                                                       * 
 * Apache2 is not running

Hi from the messages i think you are running docker using
this command:

docker run --runtime=nvidia -it --rm -v /home/petteri/test_Niftis:/workspace/clara-experiments -e NVIDIA_VISIBLE_DEVICES=1 $dockerImage /bin/bash

Can you try using the below command

docker run --runtime=nvidia -it --rm -v /home/petteri/test_Niftis:/workspace/clara-experiments -e NVIDIA_VISIBLE_DEVICES=1 -p 5000:80 $dockerImage /bin/bash

In here we are specifying that inside the docker port 80 is mapped to your machine’s port 5000.
So that in your browser you can check http://127.0.0.1:5000/logs?lines=100,
This should work.

That indeed did the trick @yuantingh, thanks a lot! :)