Problem with USB 3.0 camera

Hi,

I’m Julien, software developper and I work at First Light Imaging in France.
I developped a software in order to control and grab images from our USB3.0 cameras.
The cameras use the full bandwith of the USB3.0 to send 640x512 16bits images at 600fps.
First i tried on the jetson TX2 and nano, i lauched the software with the chrt option in order to not be preempted by the system, and the software ran well with no images lost.
Then i tried with a jetson Xavier AGX which is much better than TX2 but the software had lot of images lost and it is useless.
The only difference that i seen between the two systems is the USB3.0 5Gb/s for Tx2 and USB3.1 10Gb/s for xavier.
Why xavier can’t correctly grab all the images from the camera?

Thanks.

Hi,
Please check Jetson Nano FAQ
Q: I have a USB camera. How can I lauch it on Jetson Nano?

This is typical way of launching USB cameras on Jetson platforms. Please check if you can follow it and launch the camera successfully. YUV422 such as YUYV or UYVY is general format.

Hi,

Tanks for your help but I think that this is not the solution, we do our own cameras and we developped the USB3.0 thanks to a cypress FX3 controller, and in the software i developped a USB interface that uses the Cypress API which uses directly the libusb library to grab images.