Problema audio HDMI con EVGA GeForce GT 640

Hi all, I apologize in advance for my uncertain language English but I am Italian.
I have a problem with the audio of HDMI from my video card.
I installed the video drivers and working properly, but no sound is heard from the TV through the HDMI cable.
The card works properly, as installed on the PC dual boot with Windows Seven and Linux Opensuse, Seven and everything is working correctly when you have installed the downloaded driver from the NVIDIA website, but on Linux with the same operation no.
I was wondering if in addition to the graphics driver i hand to install an audio driver (as can happen even on windows sometimes, even if it is not my case).
Or I do not know. I ask for your help to try to solve the problem.

Salve a tutti, ho un problema con l’audio dell HDMI della mia scheda video.
Ho installato i driver video e funzionano correttamente, ma l’audio non si sente dalla TV attraverso il cavo HDMI.
La scheda funziona correttamente, dato che sul PC ho installato in dual boot Windows Seven e Linux Opensuse, e su Seven funziona tutto correttamente avendo installato il driver scaricato dal sito ufficiale NVIDIA, ma su Linux con la stessa operazione no.
Mi chiedevo se oltre al driver grafico dovessi installare un driver audio (come può accadere anche su windows a volte, anche se non è il mio caso).
Oppure non so. Chiedo il vostro aiuto per provare a risolvere il problema.

ciao, ti scrivo direttamente in italiano (english translation to follow)

Opensuse usa pulseaudio? in caso affermativo dovresti installare qualcosa come pulseuadio volume control che ti permette di decidere a quale output mandare l’audio (scheda audio interna o uscita hdmi)
Inoltre, controlla con alsamixer che i volumi non siano settati a zero.

If Opensuse uses pulseaudio try using pulseaudio volume control and switch output from internal card to hdmi. moreover check with alsamixer if any volume is set to zero.

Hello and thank you for your answer, I believe that the use pulseaudio, pulseaudio package are all installed (should be the package pavucontrol), volumes are up and gives me the ability to move the audio source on internal audio or HDMI HDA nvidia . But if I move over HDMI can not hear anything on TV.
I do not have Alsamixer but Kmix pre-installed on Opensuse, and they are all at the most.
The one that makes me VLC is set to alsa HDMI output within the settings and “feel” … So it’s just a matter of settings imagine!?

Maybe I should enable them exit from Grub? as someone who has a AMD / ATI inserts radeon.audio = 1 in grub boot.
Likely?


Ciao e grazie mille per la risposta, credo che usi il pulseaudio,sono tutti installati i pacchetto pulseaudio (dovrebbe essere il pacchetto pavucontrol), i volumi sono al massimo e mi da la possibilità di spostare la fonte audio su audio interno o HDA nvidia HDMI. Ma se sposto su HDMI non si sente nulla dalla tv.
Io non ho Alsamixer ma Kmix preinstallato su Opensuse, e sono tutti al massimo.
L’unico è VLC che mi fa impostare su alsa l’uscita HDMI all’interno delle impostazioni e “si sente”… Quindi è solo questione di impostazioni immagino!?

Forse dovrei abilitarle l’uscita dal Grub? come chi ha una AMD/ATI inserisce radeon.audio=1 nel grub di avvio.
Probabile?

non ci dovrebbe essere bisogno di toccare la configurazione di grub…
prova una cosa: apri pavucontrol e vai al tab “configurazione”, dovresti avere 2 voci

apri il “profilo” di HDMI audio controller e dovresti trovare molte voci, io ho 4 “digital surround” e 4
“digital stereo”. provale tutte e con una di queste (io sto usando la quarta digital stereo) dovresti avere il suono alla tv.

You shouldn’t need to config grub.
try opening pavucontrol and go to the configuration tab
you should have 2 elements, one of which should be “hdmi audio controller” and open the profile menu. here you should have many elements (i have 4 digital surround and 4 digital stereo), try selecting all of them, one should give you sound on your tv (for me it’s the fourth one)

As you can see in the HDMI audio settings I only have one channel (except off).
In OpneSuse forum suggested me to install native drivers through what they call the “hard way”:
http://en.opensuse.org/SDB:NVIDIA_the_hard_way
But I have them installed through the direct link:
http://en.opensuse.org/SDB:NVIDIA_drivers

Does it matter?


Come puoi vedere nelle impostazioni audio dell’hdmi ho solo un canale (eccetto spento).
Nel forum di OpneSuse mi suggerivano di installare i driver nativi attraverso quella che definiscono la “strada difficile”.
Io invece li ho installati attraverso il link diretto.
Fa differenza?

These are my audio configurations:

ALSA:
Advanced Linux Sound Architecture Driver Version 1.0.25.

SOUND MODULE:
0 snd_hda_intel
1 snd_hda_intel

CODEC:
0 [PCH ]: HDA-Intel - HDA Intel PCH - HDA Intel PCH at 0xf7410000 irq 46
1 [NVidia ]: HDA-Intel - HDA NVidia - HDA NVidia at 0xf7080000 irq 17

a questo punto non saprei cosa consigliarti, io installo i driver dalle repository di kubuntu… se non di provare ad eseguire alsamixer da terminale e verificare che uscita hdmi e relativi volumi siano funzionanti…

at this point i’m out of suggestions, i install the nvidia driver from the kubuntu repository. one thing i reiterate is to try alsamixer from the konsole and check that hdmi otuput is enabled and volumes are not muted