Problems adding a gripper (Robotiq 3 Finger Gripper) to an UR10

Hello,

I have a problem with the UR10 and the Robotiq 3 Finger Gripper.
I imported the gripper from URDF and tried to add the gripper to the UR10 provided by NVIDIA as per this tutorial:

Now, as one can see in the picture, the collision box of the gripper is not moving in a physics scene.

I am totally out of ideas. I tried to use the UR10 with the long and short suction as a base and replace the suction with the 3f gripper. This lead to different yet strange results from the gripper just falling down to the whole robot “exploding”, probably due to self collisions.

Anyone know, what I’m missing?

Thank you

PS: attached are both the gripper as well as the UR10 with the gripper connected as usd files.

ur10_with_3f_gripper.zip (162.7 KB)

Hello Johann. Thanks for sharing your problem with us and providing the assets that allow us to reproduce the issue.

Because the Hand Gripper constitutes on another articulation chain, there are a few things that need to be adjusted to attach it to the robot:

On the Gripper USD:

  1. Select the default prim and remove the Articulation API
  2. remove the Root Joint prim.

On the UR10 short gripper USD:

  1. replace the usd path from the short gripper to the Gripper USD on the USD Paths tab.
  2. move the Gripper USD out of ee_link on the stage editor.
  3. select /ur10/wrist_3_link/ee_fixed_joint.
  4. Open the Relationship Editor in Window->Isaac->Relationship Editor, and change body1 to /ur10/short_gripper/palm.
  5. remove /ur10/ee_link.

Additionally, this asset led us to discovering a bug in which sufficiently large masses at the end of the articulation chain are causing the articulation base to not behave as expected. We will work to solve this issue in future releases, but for the time being, the suggestion is to override the gripper masses to 0.01 or less for all links.

Regarding the Physics Debug View, in order to have the collision bodies updated on screen during simulation, you must enable Update to USD in Physics->Settings.

1 Like

@rgasoto
Wow, thank you very much! Your tutorial solved my issue and helped me create a working USD of the robot.
I have only additional comment for future readers. For the ee_fixed_joint I had to change PhysX Properties -> Physics Joint -> localRot1 to [1.0, 0.0, 0.0, 0.0]. Otherwise, the gripper would rotate by 90 ° on the first timestep.

Moreover, I’m happy I could help you find a new issue to make Isaac Sim even better :)

Thank you again for your help and Isaac Sim in general

Johann

1 Like