Problems after installing proprietary drivers on Debian

System info

  • Hardware model => ASUSTeK COMPUTER INC. ROG Flow X16 GV601RM_GV601RM
  • CPU => AMD Ryzen™ 7 6800HS with Radeon™ Graphics × 16
  • Graphics => NVIDIA GeForce RTX™ 3060 Laptop GPU / AMD Radeon™ Graphics
  • OS Name => Debian GNU/Linux 12 (bookworm)
  • GNOME version => 43.9
  • Windowing system => X11

Hello everyone,

recently I decided to dual boot Windows 11 and Debian on my Asus Flow X16 machine.
Everything worked perfectly until some applications caused my external monitor (Acer XB281HK) to black screen and freeze after I fullscreened them. Those apps include:

  • WebCord
  • VSCode
  • VSCodium

So I searched around online and found that G-sync on my monitor might be the cause of the issue, but to turn off G-sync you need to have access to nvidia-settings command for which you have to install proprietary drivers.
I followed this guide to install the drivers. The guide mentioned that I have to follow instructions on this page so the drivers can work properly on my laptop and after uninstalling xserver-xorg-video-intel (which was one of the requirements for method 1 to work) everything was working fine.

I haven’t touched G-sync settings at all but the black screens and freezes no longer happen which is good. However, now my external and internal monitor share the scaling and I cannot change the orientation of my internal monitor.

First of all, I cannot have my external and internal monitor share the scaling. I need my internal monitor to have a scale of 150% or 175% (which I currently don’t see as an option in display settings) and my external monitor at 100% scaling. Currently they are both at 200%.
Second of all, I want my internal monitor to have an orientation of Landscape flipped (because of tent mode) but I don’t see that option in my display settings aswell. Whats more is that in my control panel/center, whatever it is called (the panel in the top right of the screen with sound, WiFi, battery and that), I now see an option “Auto Rotate” which wasn’t there prior to installing the drivers. In short, that option doesn’t do anything and it doesn’t do any kind of auto rotation when I flip my laptop.

I tried to fix this by trying to start a Wayland session so I followed the instructions written in the “Wayland” part of the installation guide. Long story short, after completeing the tasks mentioned in the guide I still see no Wayland option when entering Debian.

Any kind of help will be very appreciated! :)

P.S.
I would have provided more links but “New users can only create posts with four links” ;(

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

I couldn’t attach it to my post as I am getting an “422: Unprocessable entity” error…

nvidia-bug-report.log.gz (440.1 KB)

Everything seems to be correctly set up, the internal display is driven by the amd igpu, the external display by the nvidia gpu.
I’m a bit puzzled that there’s no orientation settings, can you provide a screenshot of the display settings panel?

Here are the screenshots:
display-settings-screenshots.zip (106.1 KB)

I couldn’t put them all together in one post because:
“New users can only put one media file…”

That’s really odd. Does the orientation mode drop-down for the internal display appear if you disable “auto-flip”?

Nope, the auto-rotate button might as well not be there at all. I should mention however that autorotation doesn’t even work on Windows 11.
So it might be a hardware issue with the rotation detector?

Looks like the gnome on debian is too old, this was a bug/feature that was fixed:
https://gitlab.gnome.org/GNOME/gnome-control-center/-/issues/1018
The sensor might very well be defunct, there doesn’t seem to be an orientation lock button on that device.

I guess I will try some other distro then and see if my problems appear again.

I’d recommend that, too. For your hardware you should use something with more recent software that debian.