Problems for identifying zed camera on Jetson TX1

hi everybody,
I own a JTX1 with Jet Pack 2.1 32bit and I have installed ZED_SDK_Linux_JTX1_v1.1.0_32b_JP21 driver. On windows, I updated the Zed with the latest firmware (1142).
I have many problems withs Zed camera on Jetson TX1:
-ZED Explorer does not recognize the id of the camera and asks to update the firmware.
(>> Detected S/N for ZED Camera : -1)

-ZED Explorer does not load the conf file in setting folder (SN2973.conf).
(Configuration File for the Camera doesn’t exist)

-In Settings/Calibration of ZED Explorer, all value are N/A

-ZED Explorer display just stereo image and if I change quality and fps, the quality and fps change in ZED Explorer and I have a fail message
( SET failed Bad address. (System code: 14)) && (Configuration File for the Camera doesn’t exist)

If in ROS, I use zed_wrapper_node, I have a loop with warning for zed firmware not update, no calibration file found and SET failed Bad address. (System code: 14).

If you have an idea of where the problems may come?

Best regards
S.D

Hi, you may want to contact Stereolabs Support about the condition with ZED SDK.
Since then, there has also been a TX1 software update released (JetPack 2.3). For ZED SDK, you may need to ask for aarch64 build.
You can also use V4L2 directly to get the video source (V4L2 example).

Any chance to get a CUDA 7 package that will install in the 64 bit user environment with JetPack 2.3? The Zed camera sdk seems to want CUDA 7, even when using the beta zed sdk that is meant for 64 bits. I wasn’t successful in finding the right package to download (I found cuda-repo-l4t-r23.1-7-0-local_7.0-71_armhf.deb but that is armhf not arm64). Any other insights or instructions are welcome…

Thanks for your help!

  • Joe

Do you specifically want version 7 and not 7.5? You can get either on 64-bit L4T.

There is a general downloads page here (you have to log in I think):
https://developer.nvidia.com/embedded/downloads

From there you can put “cuda” in the filter and limit to items related to CUDA. The one labeled with version 23.1 provides CUDA 7.0. If you go to the R24.1 page I think it is CUDA 7.5 (I have not verified), and R24.2 (brand new) lists CUDA 8. I download these manually because I use a Fedora host and can’t run JetPack from Fedora.

Thank you for the answer.
I have already sent an email to STEREOLABS support.
I await their response.
I will try to test the JetPack 2.3 64bit. I think ROS can not operate with a arm64bit architecture.

CUDA under 32-bit is limited to CUDA 6.5, so if CUDA 7+ is required, then there will be no choice about operating 64-bit.

I solved the problem by installing version 2.1 of Jetpack 64bit and using the driver supplied by STEREOLABS.
Thank you for your help.
cordially

Does that mean that you will not run the ZED cam in ROS?

I have just installed Jetpack 2.2 with 32bit tegra stuff on JS Tx1. Successfully installed and then installed indigo_DESKTOP ROS in it. getting to work ZED CAM here is such a pain…

I am not successful yet.
Do you think you have an advice for me?

Thanks

Hi Anachronism,

I ran in similar issues.

I had to revert back to JP2.1 and use ZED_SDK_JTX1_1.1.0_32b_JP21.run. This ZED SDK doesn’t work correctly on JP2.2 (or JP2.2.1). StereoLabs isn’t planning on supporting 32bit SDKs any more, so they won’t fix ZED_SDK_JTX1_1.1.0_32b_JP21 to work with JP2.2 or JP2.2.1, which is a real bummer if you are stuck with 32bit (In my case due to dependency on ROS Indigo).

Galto

Thanks

Thanks Galto !..
You are right. I solved my problems and on my way I wrote a guide for newbies. I will see where I can post. It is 22 pages long with screen shots of every possible step.

Sorry for writing back late…

Hi Anachronism/Galto,

Thanks for your posts, I am working through the same problem currently. Unfortunately the micro USB port on my TX1 is falling off so I’ll need to get a new board before I can try out JP2.1 with the ZED SDK 1.1. I’m also saddened that they are dropping support for 32bit as I too am using ROS Indigo. Anachronism, have you posted your guide anywhere yet?

Good afternoon. Now the camera zed perfectly works at jetPack 2.3 64 bit with the new version of SDK ZED 1.1.1, at me also without problems ROS kinetic was set and in it earned zed ros wrapper as with RVIz and with rtabmap_ros.

Indeed, the word on the block is that ROS Kinetic can now be “apt-get-installed” on JP2.3 64b, thanks for confirming this Andrew.

I am planning on making the move to JP2.3 64b over the weekend.