Problems installing and booting using USB


We have installed a system on a Jetson Orin Nano on USB using sdkmanager. We have had several problems:

  1. We have only been able to install it on a 256 GB flash drive although the operating system occupies much less. When we tried to install it on several 64 GB pendrives the process failed and gave us the following error message:

Error: Invalid argument during seek for read on /dev/sda
[ 9]: l4t_flash_from_kernel: Error: partprobe failed. This indicates that:

  • the xml indicates the gpt is larger than the device storage
  • the xml might be invalid
  • the device might have a problem.
    Please make correction.
    Flash failure
    Cleaning up…
  1. The installed system is extremely slow to boot and use.

These problems do not occur when we install the system on a 64 GB microSD.

We need help to solve these problems, because we want to be able to boot using flash drives.


Have you tried formatting the USB drive before flashing?
It you have done it and it still did not work, then can you please check the exact sector size of the USB drive?

sudo fdisk -l

Then modify the num_sectors= field in Linux_for_Tegra/tools/kernel_flash/flash_l4t_external.xml and try again.


Thank you for the information.

I was using USB drives formatted with the ext4 format.

I have manually changed the value in the file “flash_l4t_external.xml” and it worked. Would it be possible to do this automatically when using the installation scripts?

Is it normal that the Jetson Orin Nano takes more than 40 seconds to boot when the older and slower Jetson Nano only takes around 25 seconds?
Is it due to the hardware, the booting process, the kernel version?
Is it possible to simplify the booting process and reduce the booting time?

It only needs to be done once.

Please file a new topic if it’s not related to the original issue.