Problems installing PGI Community Edition 17.10


I’ve tried to install the lates PGI Community Edition (v17.10) on a fresh Windows 10 system. Doing this I followed the instructions given on

  • installed the Windows SDK
  • installed Visual Studio 2015 with Visual C++
  • then installed the latest PGI Community Edition
    (all done with an administrator account)

The result of this is somewhat disappointing:

  • The x86 compilers F77 and F90/95 compilers got installed.
  • There was no option given to install the x64 compilers on first run. (This could however be solved by re-running the installer.)
  • There is no Visual Studio integration happening. (This could be expected given that VS is a prerequisite)
  • None of the CUDA toolkits was installed, not any of the provided versions.
  • The compilers are not properly linked with the system. No environmental variable set.
  • The PGI CE bash is closing a few milliseconds after trying to start.

Is this how the installer is intended to behave?
Am I missing an important step of the installation that prevents it from working properly?

Kind regards,

PGI Community Edition for Windows does not support PVF.

We have not determined if PVF can have a Community Edition, given
our relationship with Microsoft and Professional PVF.

We use Visual Studio Community Edition, to obtain the Windows utils
we would normally have to pay for. So VS 2015 Community Edition
is used to make 64-bit pgfortran and pgcc work on Windows.

But not PVF.

This is happening to us, too. I’ve detailed what is happening in a new thread.

Did you get anywhere with your problem? Thanks.[/url]

By “problem” do you mean installing PGI CE only works in the default
C:\Program Files\PGICE ?

No we have not addressed that yet.