problems of fftw 3.1.2--undefined `rfftwnd_f77.....?

I tried configure and use fftw2.1.5, all success, then I tried fftw3.1.2, with the same configure as I configured fftw2.1.5
./configure CC=“pgcc” CFLAGS="-O3 -fastsse -Mvect=sse -tp k8-64" F77=“pgf90” FFLAG="-O3 -tp k8-64" --prefix=/hptc_cluster/user_libs/fftw3.1.2
make
make install

then I used it with some errors:

$ make
mpif90 -c -O3 -I/hptc_cluster/user_libs/fftw3.1.2.float.pgi/include turb.f90
mpif90 -c -O3 -I/hptc_cluster/user_libs/fftw3.1.2.float.pgi/include mpifft.f90
mpif90 -c -O3 -I/hptc_cluster/user_libs/fftw3.1.2.float.pgi/include set_plans.f90
mpif90 -o oturb -L/hptc_cluster/user_libs/fftw3.1.2.float.pgi/lib -lfftw3f -l fftw3f_threads turb.o mpifft.o set_plans.o
mpifft.o: In function mpifft3drc_': mpifft.f90:(.text+0xde): undefined reference to rfftwnd_f77_real_to_complex_’
mpifft.f90:(.text+0x2ff): undefined reference to fftw_f77_one_' mpifft.o: In function mpifft3dcr_’:
mpifft.f90:(.text+0x65f): undefined reference to fftw_f77_one_' mpifft.f90:(.text+0x73c): undefined reference to rfftwnd_f77_complex_to_real_’
set_plans.o: In function set_plan1d_': set_plans.f90:(.text+0x22): undefined reference to fftw_f77_create_plan_’
set_plans.f90:(.text+0x39): undefined reference to fftw_f77_create_plan_' set_plans.o: In function set_plan2d_’:
set_plans.f90:(.text+0x7d): undefined reference to rfftw2d_f77_create_plan_' set_plans.f90:(.text+0x98): undefined reference to rfftw2d_f77_create_plan_’
set_plans.o: In function destroy_plan1d_': set_plans.f90:(.text+0xba): undefined reference to fftw_f77_destroy_plan_’
set_plans.f90:(.text+0xc4): undefined reference to fftw_f77_destroy_plan_' set_plans.o: In function destroy_plan2d_’:
set_plans.f90:(.text+0xda): undefined reference to rfftwnd_f77_destroy_plan_' set_plans.f90:(.text+0xe4): undefined reference to rfftwnd_f77_destroy_plan_’
make: *** [oturb] Error 2

==========
in fftw2.1.5 I can find those symbols defined, but not in fftw3.1.2, I tryed some more configures of fftw3.1.2, such as --enable-float, --enable-long-double…, all met the same errors with the application of turb f90 programs.

Will anybody help me out? Thanks very much!
sad

Hi Sad,

Looks like they removed these symbols when they changed how they did planning. See:
http://www.fftw.org/fftw3_doc/Upgrading-from-FFTW-version-2.html#Upgrading-from-FFTW-version-2

  • Mat