Problems running example CUDA files

Hi All,

I have finished getting everything compiled and now the examples are there but every time I try to run them I get these kinds of errors:

cudaSafeCall() Runtime API error in file <particleSystem.cu>, line 104 : unknown error.

the above error is with the particle example

cudaSafeCall() Runtime API error in file <bodysystemcuda.cu>, line 93 : unknown error.

the one above is for the nbody example

none of the others work either. Any ideas? Thank you

What driver and toolkit are you using? If you’re using 2.2, make sure you’re running a 185.18.xx driver.

We were using 180, just uninstalled and installed 185 from the binary and now we’re having a ton of other problems. Is 185 stable? Basically now when he turns on his system it starts GDM but says that x server isn’t running. How do we turn x on? Also we had an issue with 185 where glx isn’t working correctly with 185:

glxinfo| grep direct

spits out

Xlib: extension “GLX” missing on display “:0.0”.

we’ve already made sure that module is set to “glx” in xorg so that isn’t the problem. Any ideas?

yeah, 185 is stable (more stable than 180, in my experience)…

I’m guessing that somehow the driver didn’t install correctly. Does lsmod | grep nvidia return any results?

it shows:

nvidia 8123768 0

the install went through with no problems what so ever but when we have driver as “nvidia” in xorg now the system panics and won’t even get past a terminal. I don’t think that the install went bad, no errors at all and this happened two times after a fresh install.

Also when we go into nvidia-settings it’s saying that x server isn’t on and then when we tried to do the sample it spit out the errors about glx not functioning.

what distro is this?

also, can you attach the output of nvidia-bug-report.sh? I’m a little confused if the kernel module is loading but X is blowing up unless Xorg.conf is totally broken. Did you rebuild it when you reinstalled?

He is running Ubuntu 9.04. I know that it’s not officially supported by nvidia but all the forums say that the Hardy version works just fine in Jaunty.

no I told him not to worry about rebuilding it. We added under device: driver “nvidia” and that caused the panic, he then nano edited the xorg and removed the driver line and now he’s able to get in with no problem but of course it’s using the Vesa default driver so the resolution is horrible (800x600). I think he’s going to use the nv driver for the time being until this issue is solved.

I have attached the bug report.

Here is the order of how we did things:

Installed 185.XX driver (newest one) via binary, no errors at all

rebooted – received x server error but were able to get into gnome (I’m not even sure if that’s possible but when we ran nvidia-settings it said that x wasn’t running)

Installed the toolkit with no problem

Installed the SDK, no errors after a few installs with minor programs

Friend tried simpleTexture file that is included in the examples, said “TEST PASSED”

Friend tried the BlackScholes file that was included in SDK and it said, “TEST PASSED”

Tried fluidsGL example

spit out “Xlib: extension “GLX” missing on display “:0.0”.”

then spit out

Error: couldn’t find RGB GLX visual or fbconfig

decided to uninstall 185 and go back to 180 using the Ubuntu Hardware Manager method instead of binaries, installed no problem, x started up, 1920 resolution like he wants

then tried CUDA and of course you know that that didn’t work because it requires 185

So that’s what we’ve done and the errors we’ve seen, bug report is attached.

Thanks for the help, he is a native Windows user but his g/f uses Ubuntu and he has read all over the place that CUDA runs 20-100% faster in Linux so he wants it up and running but is running out of patience.
nvidia_bug_report.log.gz (40 KB)

ohhhh, I bet I know what’s going on.

try this: https://help.ubuntu.com/community/NvidiaMan…ting%20Software

Ubuntu has its own driver installed as a package. The NVIDIA installer writes its own driver on top of it. Ubuntu gets cranky and decides to wipe out the driver you installed but not completely, and back and forth and back and forth.

(9.04 does run fine, it is actually running fine to my immediate left with emacs, compiz, and a CUDA test harness)

Try editing the /etc/default/linux-restricted-modules-common file to include:

DISABLED_MODULES=“nv nvidia_new”

this should keep the ubuntu restricted modules from overwriting your config on reboot.

N.

EDIT: nevermind :)

Well, we got it up for a bit and then…a series of updates from the repos totally threw it off. Are the Jaunty computers that you are running up to date? It was working brilliantly but I told my friend to do the CUDA stuff first just in case it didn’t work so we didn’t waste an hour or longer for updates. Worked great, did the updates next…now it’s all messed up again.

I know this isn’t NVIDIA’s problem, I’m also posting in ubuntu forums about it.

Did you download a linux kernel update? If so, you probably need to reinstall (recompile) the driver.

N.

yeah that did it…I wish the binary automatically went over to the new driver like Ubuntu has it do when it goes through the hardware drivers method.

Is Nvidia considering getting a repository up so we can get newer drivers a bit easier? Jaunty is only at 180 and I doubt it’ll be up to 185 for another few months. Thanks!

You can also install nvidia drivers using Envy.

Never used it myself but I hear it works quite well.

N.