Problems setting up NVMe drive for cloud native demo

I am trying to set up the NVMe drive for the the cloud native demo.
I have followed the instructions from
the jetson cloudnative demo git hub repo
When I try to run this:
/dev/nvme0n1 /home/nvidia/nvme ext4 defaults 0 1
it returns: permission denied /dev/nvme0n1
I have tried sudo and giving the file permission but still get
permission denied.

What is this command for?

/dev/nvme0n1 /home/nvidia/nvme ext4 defaults 0 1

Its from the Cloud native demo github repo.

Adding this to /etc/fstab assumes your NVME drive is working and has an ext4 partition, and would allow to easily mount it to nvme folder in your home directory.
Note that you would have to create the nvme directory if it doesn’t yet exist.
Not sure, but I suspect your are giving the drive, not the partition id, it may be something like /dev/nvme0n1p1.

You would first try to mount manually:

mkdir -p /home/nvidia/nvme
sudo mount /dev/nvme0n1p1  /home/nvidia/nvme

If it mounts ok, you would unmount:

sudo umount /dev/nvme0n1p1

then edit /etc/fstab and add the entry with partition, mount point, ext4 and options and save. Then run:

sudo mount -a

and it should mount it.

1 Like

Read again what it says. You add this line to /etc/fstab to automount

Hi,

I would suggest you try with Honey_Patouceul’s suggestion first.

  1. Please try with the partition id.
  2. Have you created this folder “/home/nvidia/nvme” already?

The github also tells you need to mount the nvme disk to /home/nvidia/nvme first as Honey_Patouceul’s comment here. Have you tried it?

I didn’t realize that you have to use a editor to open: /etc/fstab
and then paste the line in there.
I was just trying to run it.
I think Homer Simpsom put it best “Doh”
Thanks for the help.