Problems using acml in 5.2


We have a fortran code that makes extensive use of LAPACK and BLAS routines. We’ve been compiling it with pgf90 5.2 and using the LAPACK and BLAS library included with 5.2. The code runs well with this arrangement.

Recently we decided to try using the acml library to see if we can get a speed imporvement. We sucessfully compiled the code with pgf90 and linking it with the acml library included with 5.2. However, when we tried to run the code, we got a floating point exception as soon as the code tried to call a BLAS routine. I tried compiling with the -Mcache_align switch, and it didn’t help.

We are using an Opteron 248 system running red hat. Any insight into the problem would be greatly appreciated.

Hi Kwa,

Do you know which routine is causing the problem? We reported an issue to AMD where ACML’s DGETRF/DGETRS routines can cause programs to seg fault when given large matrices (This should be fixed in ACML version 2.7).

Can you post a small example which exhibits the problem?


Thanks for the reply mat.

According to the debugger, the exception is caused by the subroutine ZTRSM, which was called by ZGETRF. Since ZGETRF is the double complex version of DGETRF, maybe it’s the same problem?


Hi Ken,

It’s possibly the same bug. Try reducing the matrix size since the error only occurs with large matrices.

The rumor around here is that ACML 2.7 should be out very soon, but we don’t know exactly when. Note, since ACML 2.6 and 2.7 are being built with PGI 6.0, you will need to upgrade to 6.0 in order to use them.

  • Mat