Problems when compiling Molpro with -fastsse

I compiled Molpro with -fastsse following the instructions on
your website.

The machine has two Xeon CPUs so I linked it to Intel MKL 7.0 (ACML is not as fast on Intel CPUs but I could try ACML or ATLAS if anybody thinks that this is the problem.) When I compiled Molpro with Intel Fortran 7.1 before everything worked fine when using MKL.

The problem is that some testjobs fail. In ‘make quicktest’ everything is OK but in ‘make test’ the following jobs fail:
casvb, casvb2, h2o_mp2pol

The error message in h2o_mp2pol was

ILLEGAL ADDRESS IN CORLSR: LT= -1 IBASE= 106793329 LTOP= 106892473 MEMSTACK= 108793329

ERROR EXIT
CURRENT STACK: MAIN

while the error message in the other two tests was only

ERROR EXIT
CURRENT STACK: MAIN

Does anyone have an idea?

andre42,

We just compile MOLPRO with PGI 5.2-1 compiler on Xeon with -fastsse as an option and we use ATLAS tuning for P4SSE2 .
Here is the result we got.

casvb passed.
casvb2 failed, so as IFC7.1(-O3) and both have exactly the same errors. We are still investigating what exactly is going on.
h2o_mp2pol , I did not see this test anywhere in testjobs directory. I just downloaded molpro tar file today and still did not see this test.

We will do some experiment with MKL and will let you konw in the near future.
Below are some definitions in CONFIG file for P4. You might want to compare with your config file, there might be something different that could cause an error in casvb.


----------------CONFIG----------------------------
CC=“cc -Dpgf90”
FC="/usr/pgi_rel/linux86/5.2-1/bin/pgf90 -pc 64 -i4 -Mscalarsse -Mcache_align"
F90="/usr/pgi_rel/linux86/5.2-1/bin/pgf90 -pc 64 -i4 -Mscalarsse -Mcache_align"

LINKFC="/usr/pgi_rel/linux86/5.2-1/bin/pgf90 -pc 64 -i4 -fastsse"

FOPT="-fastsse"

BLASLIB="-L/home/hongyon/blaslibs/Linux_P4SSE2/lib -lcblas -lf77blas -latlas -Wl,-rpath,/home/hongyon/blaslibs/Linux_P4SSE2/lib"

BLASLIB_p4="-L/home/hongyon/blaslibs/Linux_P4SSE2/lib -lcblas -lf77blas -latlas -Wl,-rpath,/home/hongyon/blaslibs/Linux_P4SSE2/lib"
PARSE=parse-i686-pc-linux-gnu-i4.o.gz

Hi hongyon,

about h2o_mp2pol: I forgot to say that I tried to compile the 2002.8-Version. We use that version for some things, but I can try 2002.6.
Maybe this is also the reason for casvb failing.
But with IFC and no SSE2 everythhing is fine.

So far I head very good experiences with MKL so I’m using that for P4 and Xeon (ACML for Athlon/Opteron). Maybe I should try ATLAS.

The CONFIG file has the same settings apart from the path to pgf90 and of course the settings for BLAS/LAPACK:

BLASLIB="-L/opt/intel/mkl70/lib/32 -lmkl_p4 -lguide -Wl,-rpath,/opt/intel/mkl70/lib/32 "
LAPACKLIB="-L/opt/intel/mkl70/lib/32 -lmkl_lapack -Wl,-rpath,/opt/intel/mkl70/lib/32 "

BLASLIB_p4="-L/opt/intel/mkl70/lib/32 -lmkl_p4 -lguide -Wl,-rpath,/opt/intel/mkl70/lib/32 "
LAPACKLIB_p4="-L/opt/intel/mkl70/lib/32 -lmkl_lapack -Wl,-rpath,/opt/intel/mkl70/lib/32 "
PARSE=parse-i686-pc-linux-gnu-i4.o.gz

Thanks,

André