Problems with CUDA on Linux Mint 17.2 "Rafaela" with Tesla C2070


I have problem with CUDA memory allocation. When I run[/i] deviceQuery I get the response:

CUDA Device Query (Runtime API) version (CUDART static linking)

Detected 1 CUDA Capable device(s)

Device 0: “Tesla C2070”
CUDA Driver Version / Runtime Version 7.5 / 7.5
CUDA Capability Major/Minor version number: 2.0
Total amount of global memory: 5372 MBytes (5633277952 bytes)
(14) Multiprocessors, ( 32) CUDA Cores/MP: 448 CUDA Cores
GPU Max Clock rate: 1147 MHz (1.15 GHz)
Memory Clock rate: 1494 Mhz
Memory Bus Width: 384-bit
L2 Cache Size: 786432 bytes
Maximum Texture Dimension Size (x,y,z) 1D=(65536), 2D=(65536, 65535), 3D=(2048, 2048, 2048)
Maximum Layered 1D Texture Size, (num) layers 1D=(16384), 2048 layers
Maximum Layered 2D Texture Size, (num) layers 2D=(16384, 16384), 2048 layers
Total amount of constant memory: 65536 bytes
Total amount of shared memory per block: 49152 bytes
Total number of registers available per block: 32768
Warp size: 32
Maximum number of threads per multiprocessor: 1536
Maximum number of threads per block: 1024
Max dimension size of a thread block (x,y,z): (1024, 1024, 64)
Max dimension size of a grid size (x,y,z): (65535, 65535, 65535)
Maximum memory pitch: 2147483647 bytes
Texture alignment: 512 bytes
Concurrent copy and kernel execution: Yes with 2 copy engine(s)
Run time limit on kernels: No
Integrated GPU sharing Host Memory: No
Support host page-locked memory mapping: Yes
Alignment requirement for Surfaces: Yes
Device has ECC support: Enabled
Device supports Unified Addressing (UVA): Yes
Device PCI Domain ID / Bus ID / location ID: 0 / 5 / 0
Compute Mode:
< Default (multiple host threads can use ::cudaSetDevice() with device simultaneously) >

deviceQuery, CUDA Driver = CUDART, CUDA Driver Version = 7.5, CUDA Runtime Version = 7.5, NumDevs = 1, Device0 = Tesla C2070
Result = PASS

However when I try bandwidthTest:

$ ./bandwidthTest
[CUDA Bandwidth Test] - Starting…
Running on…

Device 0: Tesla C2070
Quick Mode

CUDA error at code=2(cudaErrorMemoryAllocation) “cudaEventCreate(&start)”

I also get code 2 whenever I run cudaMalloc every time.
Please help!

I don’t think Linux Mint 17.2 is an officially supported linux distro for CUDA.

Try rebooting the machine.

Linux Mint 17.2 is Ubuntu 14.04 derivate so it should probably work.
Tried rebooting, tried installing 7.0 CUDA driver, but still the same error…