Problems with TK-1 install

This is my first time installing Linux. I have experience on BSD but Linux is whipping me bad. I can get the software installed no problem. Well after working through some issues anyways. The hitch is getting the correct video driver isntalled, I picked the option to install the video driver on the pc but when I go to additional drivers its not listed and trying to run samples results in an error saying I don’t have enough GPU to run the program. I have a 660TX plenty enough to run them. So I’m wondering if the driver is installed. Did a listing of the dpkg repo and its there. 331 and 340. The Nvidia page says if you are going to cluster use the latest driver so I downloaded 352 thinking I’d install it manually so I could see what is going on. Go to single user turn off lightdm install and it all says ok. It does pop up an error at the beginning saying the preinstall script failed. But the script continued and I looked at the script didn’t look significant to me. In fact it looks like its intentional. So everything works fine until I reboot then I get no window manager just a cursor in the upper left corner. Booted into recovery mode and did dpkg to try and get everything working. It fails on a file related to opencv saying it can’t modify it. The only way I’ve been able to get my GUI back is to do a purge on nvidia and go back to the driver then to 331 via the additonal drivers app. And all looks well but I’m back to not having the capability to run the samples recompiled for the pc. If I try and go straight to installing the 352 driver before trying to install the Jetpack then it won’t come up at all. Puts the icon on the bar and nothing further happens. And I have more Jetsons on the way tomorrow so I don’t want to have to go through another install just so the JetPack will function. Is there a sequence on how to set up a fresh linux install so it will run all this stuff correctly. Are there updates that need to be done before trying Jetpack? I’ve tried it that way and ended up not being able to start JetPack. I thought if you tell the JetPack script to install the driver the next time you restarted it would be the default but it doesn’t seen to work that way. And I think I’m probably messing it up myself just don’t know enough about linux yet not too. On the other hand once flashed the Jetsons rock. Once you add some swap for big compiles they are excellent. OpenMPI compiled no problem and works great. I’ve looked on the net and found several recipe’s but none of them seem to work properly. Starting to wonder if my hardware isn’t monked. It should just install. The resolution is so low on the driver I can’t read the xterms or I’d leave it and use it just to install new updates. The Jetsons compile quick enough. But I’d like to use the profiler and nsight as well. So a link to a current install sequence would be much appreciated. Or a way to do it manually on the pc side. I’ve tried that and haven’t had any sucess either. I can get the part that is needed to flash the Jetson set up and it works but the rest is not correct.