Problems with Ubuntu on the jetson nano

Hi,

I have 2 mains problems.
I use my jetson nano via VNC.
When I used a keyboard on the Jetson I didn’t have any problems but now via VNC the keyboard is in QWERTY but my keyboard is in AZERTY.

On the Jetson Nano my keyboard is in FR but I still have my keyboard in QWERTY.
I try to change this in the settings, it didn’t worked,
“sudo dpkg-reconfigure keyboard-configuration” doesn’t work.
“sudo loadkeys fr” doesn’t work.
“setxkbmap fr” doesn’t work.

Is anyone had the same problem?

Also via VNC I can’t change my resolution so the window is really small to work with.
I tried to use “xrandr” and setting the reolustion higher (for example 1440x1080) but the console says that it’s not a resolution available. But When I connect the Jetson to a display it is possible to go up to 1920x1080.

Does someone know how to change the resolution on the Jetson Nano?

Sincerely,

Hi,
Did you follow the setup in below thread?

Hi,
Yes I followed this.
I did the instructions on the readme on the jetson nano but it was not enough : VNC didn’t work, and there was a bug, in the paramaters of Ubuntu it was impossible to go in the parameters for remote desktop.

I had to follow this guide for VNC : https://raspberry-valley.azurewebsites.net/NVIDIA-Jetson-Nano/
And it worked, but I still have the problems I explained on this post.

At the end of the thread you sent me it is written than someone know how to change the resolution but his link is dead.

Hi,

I am not sure about the VNC keyboard layout issue. Maybe other forum users have the idea.

But for the resolution problem I could say:

  1. It is not a problem in VNC but tegra graphic driver. We didn’t support user to add mode in xrandr. All modes must be from EDID.

  2. Some other forum user asked about xrdp too. I once shared a method to enable a virtual screen in xorg.conf.
    JetPack 4.3: MESA-LOADER: failed to open swrast while in xrdp session

Hope this would help.

Actually I wanted to connect via xdrp so I installed xdrp on the jetson nano and I tried to connect with my laptop via windows 10 remote desktop, I enter the IP address, a new windows with xorg is proposed, I enter the name of the jetson and the password, I can see the Nvidia logo for few seconds then the window is shutting itself.
That’s why I used vnc.

I followed your link and I modified xorg.conf but now the jetson wont start, I get this (cf photo)

and I don’t know how to resolve this problem without reinstall ubuntu on the jetson.

You better enabling the serial console to check what is going on by reading the xorg log.