Processes go into uninterruptible sleep during multiple transcoding.

I’m testing transcoding process with ffmpeg and couple of P4 GPU cards.

After heavy tests, whole ffmpeg processes go into uninterruptible sleep status, then nothing works.

Even accessing shell is completely slow.

i queried “nvidia-smi -a -q -d utilization”, and it said the utilization of decoder in first card is 100%.

But nothing works. they’re all in uninterruptible sleep status.

i configured GPUs like below
sudo nvidia-smi -pm 1;
sudo nvidia-smi -e 0;
sudo nvidia-smi -acp 0;
sudo nvidia-smi --auto-boost-default=DISABLED;
CLOCK=$(nvidia-smi -i 0 --query-supported-clocks=graphics,memory --format=csv | sed -n 2p | awk -F ’ ’ ‘{print $3","$1}’) ;
sudo nvidia-smi -ac $CLOCK

and versions of modules are…

FFMPEG : 3.4.0
Nvidia Driver : 384.81
Cuda : 9.0.176_384.81

Any clues?

Hi, We have the similar issue. Did you find any solution for this ?

Nevermind, with these updates problems seems gone away:

Cuda version 10.1
Nvidia Driver 418.88
FFmpeg 4.1.x