Production module not working in cold

I have observed a problem with Jetson nano, there is a problem, it works in the cold, but if we boot it at -1 or lower degrees celsius, the LAN interface is not working. We tried cooling our produciton jetson module separately from the carried board and together- same effect. We test with serial to see if it is booting and it is. Only solution we found is to unplug the ethernet and plug it back in, then LAN works. Any suggestions?

Hi, are you testing on devkit or custom board? Is there any difference in log info comparing to normal boot-up?

We are using p3448-0002 production modules. The carrier board is custom, but we tried cooling the module separatley from the carrier board and together with a carrier board. Results are the same- ethernet is not working, meanwhile in warm temperatures everything is good no matter what. Weird thing is that if we are pinging the jetson when it boots in the cold- we cannot reach it. if we do not ping it when it is booting in the cold- we can reach it over ssh after it is booted.

Do you mean you can’t get log when it is booting in the cold? It is weird and can’t analyze if no log. How many modules have you tested? What’s the fail rate?

we can get the log when booting through serial. It is identical to normal boot log. I can send it. Also i was looking inside the BSP for jetson nano alot, checking DTS files and so on. DTS file for p3448-0002 has a hardcoded (by nvidia) string that says “jetson nano development board” and it has some IMX219 drivers in the BSP by default. That is really weird as it is for production module, we aren’t using IMX 219 and values for it are hardcoded in devicetree. We tried 3 p3448-0002 modules, all behave the same. I suppose i can reformulate the issue. If we ping the nano and it is booting in the cold- it breaks the LAN. If we do the same in warm environment everything is fine. bootloader log is below. Also i must stress that we tried cooling carrier+ jetson and jetson only. Both give same results so we have strong evidence its a problem with jetson, not the carrier.


 Serial  Port opened
[0000.231] [L4T TegraBoot] (version 00.00.2018.01-l4t-8728f3cb)
[0000.236] Processing in cold boot mode Bootloader 2
[0000.241] A02 Bootrom Patch rev = 1023
[0000.244] Power-up reason: pmc por
[0000.248] No Battery Present
[0000.250] pmic max77620 reset reason
[0000.254] pmic max77620 NVERC : 0x40
[0000.257] RamCode = 0
[0000.259] Platform has DDR4 type RAM
[0000.263] max77620 disabling SD1 Remote Sense
[0000.267] Setting DDR voltage to 1125mv
[0000.271] Serial Number of Pmic Max77663: 0x2431f2
[0000.278] Entering ramdump check
[0000.281] Get RamDumpCarveOut = 0x0
[0000.285] RamDumpCarveOut=0x0,  RamDumperFlag=0xe59ff3f8
[0000.290] Last reboot was clean, booting normally!
[0000.294] Sdram initialization is successful 
[0000.298] SecureOs Carveout Base=0x00000000ff800000 Size=0x00800000
[0000.305] Lp0 Carveout Base=0x00000000ff780000 Size=0x00001000
[0000.310] BpmpFw Carveout Base=0x00000000ff700000 Size=0x00080000
[0000.316] GSC1 Carveout Base=0x00000000ff600000 Size=0x00100000
[0000.322] GSC2 Carveout Base=0x00000000ff500000 Size=0x00100000
[0000.328] GSC4 Carveout Base=0x00000000ff400000 Size=0x00100000
[0000.334] GSC5 Carveout Base=0x00000000ff300000 Size=0x00100000
[0000.340] GSC3 Carveout Base=0x000000017f300000 Size=0x00d00000
[0000.356] RamDump Carveout Base=0x00000000ff280000 Size=0x00080000
[0000.362] Platform-DebugCarveout: 0
[0000.365] Nck Carveout Base=0x00000000ff080000 Size=0x00200000
[0000.371] Non secure mode, and RB not enabled.
[0000.375] *** Booting BFS0.
[0000.378] Initialize FailControl
[0000.381] Read PT from (0:3)
[0000.396] Csd NumOfBlocks=0
[0000.435] PT crc32 and magic check passed.
[0000.439] Using BFS PT to query partitions 
[0000.443] PT: Partition LNX NOT found ! 
[0000.447] *** Booting KFS0.
[0000.449] NvTbootFailControlDoFailover: No failover; Continuing ...
[0000.455] BoardID = 3448, SKU = 0x2
[0000.459] Not Nano-SD or !QSPI-ONLY, check GPT table first ...
[0000.464] Read GPT from (0:3)
[0000.476] Using GPT Primary to query partitions
[0000.481] NvTbootFailControlDoFailover: No failover; Continuing ...
[0000.487] Loading Tboot-CPU binary
[0000.493] Verifying TBC in OdmNonSecureSBK mode
[0000.503] Bootloader load address is 0xa0000000, entry address is 0xa0000258
[0000.510] Bootloader downloaded successfully.
[0000.514] Downloaded Tboot-CPU binary to 0xa0000258
[0000.519] MAX77620_GPIO5 configured
[0000.522] CPU power rail is up
[0000.525] CPU clock enabled
[0000.529] Performing RAM repair
[0000.532] Updating A64 Warmreset Address to 0xa00002e9
[0000.537] BoardID = 3448, SKU = 0x2
[0000.540] Not Nano-SD or !QSPI-ONLY, check GPT table first ...
[0000.546] NvTbootFailControlDoFailover: No failover; Continuing ...
[0000.552] Loading NvTbootBootloaderDTB
[0000.569] Verifying NvTbootBootloaderDTB in OdmNonSecureSBK mode
[0000.641] Bootloader DTB Load Address: 0x83000000
[0000.645] BoardID = 3448, SKU = 0x2
[0000.649] Not Nano-SD or !QSPI-ONLY, check GPT table first ...
[0000.654] Loading NvTbootKernelDTB
[0000.671] Verifying NvTbootKernelDTB in OdmNonSecureSBK mode
[0000.742] Kernel DTB Load Address: 0x83100000
[0000.747] BoardID = 3448, SKU = 0x2
[0000.750] Not Nano-SD or !QSPI-ONLY, check GPT table first ...
[0000.756] NvTbootFailControlDoFailover: No failover; Continuing ...
[0000.763] Loading cboot binary
[0000.774] Verifying EBT in OdmNonSecureSBK mode
[0000.815] Bootloader load address is 0x92c00000, entry address is 0x92c00258
[0000.822] Bootloader downloaded successfully.
[0000.827] BoardID = 3448, SKU = 0x2
[0000.830] Not Nano-SD or !QSPI-ONLY, check GPT table first ...
[0000.836] NvTbootFailControlDoFailover: No failover; Continuing ...
[0000.842] PT: Partition NCT NOT found ! 
[0000.846] Warning: Find Partition via PT Failed
[0000.850] Next binary entry address: 0x92c00258 
[0000.855] BoardId: 3448
[0000.859] Overriding pmu board id with proc board id
[0000.864] Display board id is not available 
[0000.868] BoardID = 3448, SKU = 0x2
[0000.871] Not Nano-SD or !QSPI-ONLY, check GPT table first ...
[0000.877] NvTbootFailControlDoFailover: No failover; Continuing ...
[0000.891] Verifying SC7EntryFw in OdmNonSecureSBK mode
[0000.947] /bpmp deleted
[0000.949] SC7EntryFw header found loaded at 0xff700000
[0001.137] OVR2 PMIC
[0001.139] Bpmp FW successfully loaded
[0001.142] BoardID = 3448, SKU = 0x2
[0001.146] Not Nano-SD or !QSPI-ONLY, check GPT table first ...
[0001.152] NvTbootFailControlDoFailover: No failover; Continuing ...
[0001.159] WB0 init successfully at 0xff780000
[0001.163] Verifying NvTbootWb0 in OdmNonSecureSBK mode
[0001.168] Set NvDecSticky Bits
[0001.172] GSC2 address ff53fffc value c0edbbcc
[0001.178] GSC MC Settings done
[0001.181] BoardID = 3448, SKU = 0x2
[0001.184] Not Nano-SD or !QSPI-ONLY, check GPT table first ...
[0001.191] TOS Image length 53680
[0001.194]  Monitor size 53680
[0001.197]  OS size 0
[0001.202] Secure Os AES-CMAC Verification Success!
[0001.207] TOS image cipher info: plaintext
[0001.211] Loading and Validation of Secure OS Successful
[0001.227] SC7 Entry Firmware - 0xff700000, 0x4000
[0001.231] NvTbootPackSdramParams: start. 
[0001.236] NvTbootPackSdramParams: done. 
[0001.240] Tegraboot started after 160443 us
[0001.244] Basic modules init took 744838 us
[0001.248] Sec Bootdevice Read Time = 58 ms, Read Size = 3682 KB
[0001.254] Sec Bootdevice Write Time = 0 ms, Write Size = 0 KB
[0001.259] Next stage binary read took 7386 us
[0001.264] Carveout took -34782 us
[0001.267] CPU initialization took 392423 us
[0001.271] Total time taken by TegraBoot 1109865 us

[0001.275] Starting CPU & Halting co-processor 

64NOTICE:  BL31: v1.3(release):b5eeb33
NOTICE:  BL31: Built : 08:56:32, Feb 19 2022
ERROR:   Error initializing runtime service trusty_fast
[0001.397] RamCode = 0
[0001.402] LPDDR4 Training: Read DT: Number of tables = 2
[0001.407] EMC Training (SRC-freq: 204000; DST-freq: 1600000)
[0001.420] EMC Training Successful
[0001.423] 408000 not found in DVFS table
[0001.429] RamCode = 0
[0001.433] DT Write: emc-table@204000 succeeded
[0001.438] DT Write: emc-table@1600000 succeeded
[0001.442] LPDDR4 Training: Write DT: Number of tables = 2
[0001.486] 
[0001.487] Debug Init done
[0001.489] Marked DTB cacheable
[0001.492] Bootloader DTB loaded at 0x83000000
[0001.497] Marked DTB cacheable
[0001.500] Kernel DTB loaded at 0x83100000
[0001.504] DeviceTree Init done
[0001.517] Pinmux applied successfully
[0001.521] gicd_base: 0x50041000
[0001.525] gicc_base: 0x50042000
[0001.528] Interrupts Init done
[0001.532] Using base:0x60005090 & irq:208 for tick-timer
[0001.537] Using base:0x60005098 for delay-timer
[0001.542] platform_init_timer: DONE
[0001.545] Timer(tick) Init done
[0001.549] osc freq = 38400 khz
[0001.553] 
[0001.554] Welcome to L4T Cboot
[0001.557] 
[0001.558] Cboot Version: 00.00.2018.01-t210-a2f2e4b8
[0001.563] calling constructors
[0001.566] initializing heap
[0001.569] initializing threads
[0001.571] initializing timers
[0001.574] creating bootstrap completion thread
[0001.579] top of bootstrap2()
[0001.582] CPU: ARM Cortex A57
[0001.584] CPU: MIDR: 0x411FD071, MPIDR: 0x80000000
[0001.589] initializing platform
[0001.643] Config for emmc ddr50 mode completed
[0001.647] sdmmc bdev is already initialized
[0001.651] Enable APE clock
[0001.654] Un-powergate APE partition
[0001.657] of_register: registering tegra_udc to of_hal
[0001.663] of_register: registering inv20628-driver to of_hal
[0001.668] of_register: registering ads1015-driver to of_hal
[0001.674] of_register: registering lp8557-bl-driver to of_hal
[0001.679] of_register: registering bq2419x_charger to of_hal
[0001.685] of_register: registering bq27441_fuel_gauge to of_hal
[0001.697] gpio framework initialized
[0001.700] of_register: registering tca9539_gpio to of_hal
[0001.705] of_register: registering tca9539_gpio to of_hal
[0001.711] of_register: registering i2c_bus_driver to of_hal
[0001.716] of_register: registering i2c_bus_driver to of_hal
[0001.722] of_register: registering i2c_bus_driver to of_hal
[0001.727] pmic framework initialized
[0001.731] of_register: registering max77620_pmic to of_hal
[0001.736] regulator framework initialized
[0001.740] of_register: registering tps65132_bl_driver to of_hal
[0001.746] initializing target
[0001.752] gpio_driver_register: register 'tegra_gpio_driver' driver
[0001.760] board ID = D78, board SKU = 2
[0001.766] fixed regulator driver initialized
[0001.784] initializing OF layer
[0001.787] NCK carveout not present
[0001.790] Skipping dts_overrides
[0001.794] of_children_init: Ops found for compatible string nvidia,tegra210-i2c
[0001.812] I2C Bus Init done
[0001.815] of_children_init: Ops found for compatible string nvidia,tegra210-i2c
[0001.825] I2C Bus Init done
[0001.828] of_children_init: Ops found for compatible string nvidia,tegra210-i2c
[0001.838] I2C Bus Init done
[0001.840] of_children_init: Ops found for compatible string nvidia,tegra210-i2c
[0001.851] I2C Bus Init done
[0001.853] of_children_init: Ops found for compatible string nvidia,tegra210-i2c
[0001.864] I2C Bus Init done
[0001.866] of_children_init: Ops found for compatible string maxim,max77620
[0001.877] max77620_init using irq 118
[0001.882] register 'maxim,max77620' pmic
[0001.886] gpio_driver_register: register 'max77620-gpio' driver
[0001.892] of_children_init: Ops found for compatible string nvidia,tegra210-i2c
[0001.903] I2C Bus Init done
[0001.906] NCK carveout not present
[0001.916] Find /i2c@7000c000's alias i2c0
[0001.919] get eeprom at 1-a0, size 256, type 0
[0001.928] Find /i2c@7000c500's alias i2c2
[0001.932] get eeprom at 3-a0, size 256, type 0
[0001.936] get eeprom at 3-ae, size 256, type 0
[0001.941] pm_ids_update: Updating 1,a0, size 256, type 0
[0001.946] I2C slave not started
[0001.949] I2C write failed
[0001.952] Writing offset failed
[0001.955] eeprom_init: EEPROM read failed
[0001.959] pm_ids_update: eeprom init failed
[0001.963] pm_ids_update: Updating 3,a0, size 256, type 0
[0001.993] pm_ids_update: The pm board id is 3448-0002-400
[0002.000] Adding plugin-manager/ids/3448-0002-400=/i2c@7000c500:module@0x50
[0002.008] pm_ids_update: pm id update successful
[0002.013] pm_ids_update: Updating 3,ae, size 256, type 0
[0002.043] eeprom_init: EEPROM incompatible version found
[0002.048] pm_ids_update: eeprom init failed
[0002.078] eeprom_get_mac: EEPROM invalid MAC address (all 0xff)
[0002.084] shim_eeprom_update_mac:267: Failed to update 0 MAC address in DTB
[0002.092] eeprom_get_mac: EEPROM invalid MAC address (all 0xff)
[0002.098] shim_eeprom_update_mac:267: Failed to update 1 MAC address in DTB
[0002.106] updating /chosen/nvidia,ethernet-mac node 00:04:4b:e9:eb:b1
[0002.112] Plugin Manager: Parse ODM data 0x000a4000
[0002.125] shim_cmdline_install: /chosen/bootargs: earlycon=uart8250,mmio32,0x70006000 
[0002.139] Find /i2c@7000c000's alias i2c0
[0002.143] get eeprom at 1-a0, size 256, type 0
[0002.152] Find /i2c@7000c500's alias i2c2
[0002.156] get eeprom at 3-a0, size 256, type 0
[0002.160] get eeprom at 3-ae, size 256, type 0
[0002.164] pm_ids_update: Updating 1,a0, size 256, type 0
[0002.170] I2C slave not started
[0002.173] I2C write failed
[0002.175] Writing offset failed
[0002.178] eeprom_init: EEPROM read failed
[0002.182] pm_ids_update: eeprom init failed
[0002.186] pm_ids_update: Updating 3,a0, size 256, type 0
[0002.217] pm_ids_update: The pm board id is 3448-0002-400
[0002.223] Adding plugin-manager/ids/3448-0002-400=/i2c@7000c500:module@0x50
[0002.230] pm_ids_update: pm id update successful
[0002.234] pm_ids_update: Updating 3,ae, size 256, type 0
[0002.264] eeprom_init: EEPROM incompatible version found
[0002.270] pm_ids_update: eeprom init failed
[0002.299] Add serial number:1423119047989 as DT property
[0002.307] Applying platform configs
[0002.314] platform-init is not present. Skipping
[0002.318] calling apps_init()
[0002.339] Found 17 GPT partitions in "sdmmc3_user"
[0002.344] Proceeding to Cold Boot
[0002.347] starting app android_boot_app
[0002.351] Device state: unlocked
[0002.354] display console init
[0002.363] could not find regulator
[0002.386] hdmi cable not connected
[0002.389] is_hdmi_needed: HDMI not connected, returning fDT entry for leds-pwm not found
a[0002.401] lse
[0002.402] hdmi is not connected
[0002.405] sor0 is not supported
[0002.408] display_console_init: no valid display out_type
[0002.416] subnode volume_up is not found !
[0002.420] subnode back is not found !
[0002.423] subnode volume_down is not found !
[0002.428] subnode menu is not found !
[0002.431] Gpio keyboard init success
[0002.479] found decompressor handler: lz4-legacy
[0002.493] decompressing blob (type 1)...
[0002.559] display_resolution: No display init
[0002.564] Failed to retrieve display resolution
[0002.568] Could not load/initialize BMP blob...ignoring
[0002.573] -------> se_aes_verify_sbk_clear: 747
[0002.578] se_aes_verify_sbk_clear: Error
[0002.582] SE operation failed
[0002.584] bl_battery_charging: connected to external power supply
[0002.594] display_console_ioctl: No display init
[0002.598] switch_backlight failed
[0002.608] device_query_partition_size: failed to open partition sdmmc3_user:MSC !
[0002.615] MSC Partition not found
[0002.625] device_query_partition_size: failed to open partition sdmmc3_user:USP !
[0002.632] USP partition read failed!
[0002.636] blob_init: blob-partition USP header read failed
[0002.641] android_boot Unable to update recovery partition
[0002.646] kfs_getpartname: name = LNX
[0002.650] Loading kernel from LNX
[0002.747] load kernel from storage
[0002.757] decompressor handler not found
[0002.790] Successfully loaded kernel and ramdisk images
[0002.796] board ID = D78, board SKU = 2
[0002.800] display_resolution: No display init
[0002.804] Failed to retrieve display resolution
[0002.809] bmp blob is not loaded and initialized
[0002.814] Failed to display boot-logo
[0002.817] NCK carveout not present
[0002.820] Skipping dts_overrides
[0002.824] NCK carveout not present
[0002.833] Find /i2c@7000c000's alias i2c0
[0002.837] get eeprom at 1-a0, size 256, type 0
[0002.846] Find /i2c@7000c500's alias i2c2
[0002.850] get eeprom at 3-a0, size 256, type 0
[0002.854] get eeprom at 3-ae, size 256, type 0
[0002.858] pm_ids_update: Updating 1,a0, size 256, type 0
[0002.864] I2C slave not started
[0002.867] I2C write failed
[0002.869] Writing offset failed
[0002.872] eeprom_init: EEPROM read failed
[0002.876] pm_ids_update: eeprom init failed
[0002.880] pm_ids_update: Updating 3,a0, size 256, type 0
[0002.911] pm_ids_update: The pm board id is 3448-0002-400
[0002.917] Adding plugin-manager/ids/3448-0002-400=/i2c@7000c500:module@0x50
[0002.926] pm_ids_update: pm id update successful
[0002.930] pm_ids_update: Updating 3,ae, size 256, type 0
[0002.960] eeprom_init: EEPROM incompatible version found
[0002.966] pm_ids_update: eeprom init failed
[0002.996] eeprom_get_mac: EEPROM invalid MAC address (all 0xff)
[0003.001] shim_eeprom_update_mac:267: Failed to update 0 MAC address in DTB
[0003.009] eeprom_get_mac: EEPROM invalid MAC address (all 0xff)
[0003.015] shim_eeprom_update_mac:267: Failed to update 1 MAC address in DTB
[0003.023] updating /chosen/nvidia,ethernet-mac node xxxxxxxxxxxxxxxx
[0003.030] Plugin Manager: Parse ODM data 0x000a4000
[0003.042] shim_cmdline_install: /chosen/bootargs: earlycon=uart8250,mmio32,0x70006000 
[0003.050] Add serial number:1423119047989 as DT property
[0003.059] "bpmp" doesn't exist, creating 
[0003.065] Updated bpmp info to DTB
[0003.070] Updated initrd info to DTB
[0003.073] "proc-board" doesn't exist, creating 
[0003.079] Updated board info to DTB
[0003.083] "pmu-board" doesn't exist, creating 
[0003.089] Updated board info to DTB
[0003.092] "display-board" doesn't exist, creating 
[0003.098] Updated board info to DTB
[0003.101] "reset" doesn't exist, creating 
[0003.106] Updated reset info to DTB
[0003.109] display_console_ioctl: No display init
[0003.114] display_console_ioctl: No display init
[0003.118] display_console_ioctl: No display init
[0003.123] Cmdline: tegraid=21.1.2.0.0 ddr_die=4096M@2048M section=512M memtype=0 vpr_resize usb_port_owner_info=0 lane_owner_info=0 emc_max_dvfs=0 touch_id=0@63 video=tegrafb no_console_suspend=1 console=ttyS0,115200n8 debug_uartport=lsport,4 earlyprintk=uart8250-32bit,0x70006000 maxcpus=4 usbcore.old_scheme_first=1 lp0_vec=0x1000@0xff780000 core_edp_mv=1075 core_edp_ma=4000 gpt 
[0003.157] DTB cmdline: earlycon=uart8250,mmio32,0x70006000 
[0003.163] boot image cmdline: root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=ttyS0,115200n8 console=tty0 fbcon=map:0 sdhci_tegra.en_boot_part_access=1 
[0003.178] Updated bootarg info to DTB
[0003.181] Adding uuid 000000016445c8451800000018010380 to DT
[0003.187] Adding eks info 0 to DT
[0003.193] WARNING: Failed to pass NS DRAM ranges to TOS, err: -7
[0003.199] Updated memory info to DTB
[0003.207] set vdd_core voltage to 1075 mv
[0003.210] setting 'vdd-core' regulator to 1075000 micro volts
[0003.216] Found secure-pmc; disable BPMP


U-Boot 2020.04-g4335beb (Feb 19 2022 - 08:56:35 -0800)

SoC: tegra210
Model: NVIDIA Jetson Nano Developer Kit
Board: NVIDIA P3450-0000
DRAM:  4 GiB
MMC:   sdhci@700b0000: 1, sdhci@700b0600: 0
Loading Environment from MMC... *** Warning - bad CRC, using default environment

In:    serial
Out:   serial
Err:   serial
Net:   No ethernet found.
Hit any key to stop autoboot:  0 
MMC: no card present
switch to partitions #0, OK
mmc0(part 0) is current device
Scanning mmc 0:1...
Found /boot/extlinux/extlinux.conf
Retrieving file: /boot/extlinux/extlinux.conf
864 bytes read in 33 ms (25.4 KiB/s)
1:      primary kernel
Retrieving file: /boot/initrd
7159624 bytes read in 179 ms (38.1 MiB/s)
Retrieving file: /boot/Image
34265096 bytes read in 775 ms (42.2 MiB/s)
append: tegraid=21.1.2.0.0 ddr_die=4096M@2048M section=512M memtype=0 vpr_resize usb_port_owner_info=0 lane_owner_info=0 emc_max_dvfs=0 touch_id=0@63 video=tegrafb no_console_suspend=1 console=ttyS0,115200n8 debug_uartport=lsport,4 earlyprintk=uart8250-32bit,0x70006000 maxcpus=4 usbcore.old_scheme_first=1 lp0_vec=0x1000@0xff780000 core_edp_mv=1075 core_edp_ma=4000 gpt  earlycon=uart8250,mmio32,0x70006000  root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=ttyS0,115200n8 console=tty0 fbcon=map:0 sdhci_tegra.en_boot_part_access=1 quiet root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=ttyS0,115200n8 console=tty0 fbcon=map:0 sdhci_tegra.en_boot_part_access=1 
## Flattened Device Tree blob at 83100000
   Booting using the fdt blob at 0x83100000
ERROR: reserving fdt memory region failed (addr=0 size=0)
ERROR: reserving fdt memory region failed (addr=0 size=0)
   Using Device Tree in place at 0000000083100000, end 000000008317ce95
copying carveout for /host1x@50000000/dc@54200000...
copying carveout for /host1x@50000000/dc@54240000...

Starting kernel ...

[    0.000000] Booting Linux on physical CPU 0x0
[    0.000000] Linux version 4.9.253-tegra (root@onute-build-vm) (gcc version 7.3.1 20180425 [linaro-7.3-2018.05 revision d29120a424ecfbc167ef90065c0eeb7f91977701] (Linaro GCC 7.3-2018.05) ) #1 SMP PREEMPT Mon Sep 19 18:20:18 EEST 2022
[    0.000000] Boot CPU: AArch64 Processor [411fd071]
[    0.000000] OF: fdt:memory scan node memory@80000000, reg size 32,
[    0.000000] OF: fdt: - 80000000 ,  7ee00000
[    0.000000] OF: fdt: - 100000000 ,  7f200000
[    0.000000] earlycon: uart8250 at MMIO32 0x0000000070006000 (options '')
[    0.000000] bootconsole [uart8250] enabled
[    1.084447] tegradc tegradc.1: dpd enable lookup fail:-19
[    1.590171] Host read timeout at address 545c00c4
[    1.789858] imx219 7-0010: imx219_board_setup: error during i2c read probe (-121)
[    1.797559] imx219 7-0010: board setup failed
[    1.826022] imx219 8-0010: imx219_board_setup: error during i2c read probe (-121)
[    1.833588] imx219 8-0010: board setup failed
[    2.246997] cgroup: cgroup2: unknown option "nsdelegate"
[    4.501150] random: crng init done
[    4.504555] random: 7 urandom warning(s) missed due to ratelimiting

Ubuntu 18.04.6 LTS 


Last login: Thu Jan  5 13:42:30 UTC 2023 from XXXXXXXX on pts/0
Welcome to Ubuntu 18.04.6 LTS (GNU/Linux 4.9.253-tegra aarch64)

 * Documentation:  https://help.ubuntu.com
 * Management:     https://landscape.canonical.com
 * Support:        https://ubuntu.com/advantage
This system has been minimized by removing packages and content that are
not required on a system that users do not log into.

To restore this content, you can run the 'unminimize' command.

3 updates can be applied immediately.
To see these additional updates run: apt list --upgradable


The programs included with the Ubuntu system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Ubuntu comes with ABSOLUTELY NO WARRANTY, to the extent permitted by
applicable law.

Hey, maybe you have any ideas what could be going on?