profiler not giving any info


I’ve been playing around with the pgprofiler for awhile and it seems like if I do not compile and collect it in a specific folder, the profiler is blank when ran. If I move the source code to this specific folder, compile and collect it, it will work fine.

Any ideas how to fix this since I would like to organize my programs and not cram all of them in one folder.

I’m using Windows 7 x64 with PGI Workstation 10.6(64)

Commands I use to profile:
pgfortran -Minfo=ccff (+ other options) filename.f90
pgcollect filename
pgprof -exe filename

Hi WmBruce,

To have pgrpof find your projects source files that are not in the local directory, use the “-I<src_dir>” option. More than one “-I” directories can be included. Also, you can specific which profiler output file (pgprof.out) you wish to view by adding it as the last argument. For example:

pgprof -exe filename -I.\src run\pgprof.out

Since you’re using Windows, you may need to quote your path names if they include spaces or use the DOS path names.

For more detailed information, please refer to the output from ‘pgprof -help’ of the PGI Tools User’s Guide.

  • Mat

thanks mat