Program compiles in device mode but complains missing .h in emu mode


i ran into an very strange issue.

When i compile and run my program normaly everthing works fine.

But when I switch to emulation mode the numerical recipies I’m using complain that they cant find the standard c libraries (iostream …).

Im using cmake to configure my project and tested it on 2 different linux systems.

Does anybody have a similar problem or an idea what i could do?

If necessary I can provide further Information about my Program/Configuration.

Would be very thankful if somebody has an idea.


Here is the error i get in emu mode and like i said in device mode the files are found without a problem

[codebox]In file included from /home/flo/projects/src/myproject/src/mutualInformation.h:12,

             from /home/flo/projects/src/myproject/src/

/home/flo/projects/src/myproject/src/Numerics/nr.h:3:19: error: fstream: No such file or directory

/home/flo/projects/src/myproject/src/Numerics/nr.h:4:19: error: complex: No such file or directory

In file included from /home/flo/projects/src/myproject/src/Numerics/nrutil.h:1,

             from /home/flo/projects/src/myproject/src/Numerics/nr.h:5,

             from /home/flo/projects/src/myproject/src/mutualInformation.h:12,

             from /home/flo/projects/src/myproject/src/

/home/flo/projects/src/myproject/src/Numerics/nrutil_nr.h:4:18: error: string: No such file or directory

/home/flo/projects/src/myproject/src/Numerics/nrutil_nr.h:5:17: error: cmath: No such file or directory

/home/flo/projects/src/myproject/src/Numerics/nrutil_nr.h:7:20: error: iostream: No such file or directory

CMake Error at (message):

make[2]: Leaving directory `/home/flo/projects/build/myproject’

Error generating

make[1]: Leaving directory `/home/flo/projects/build/myproject’


You mention that you are using cmake to configure. I’m one of the developers of the FindCUDA.cmake script found here: Are you using that?

STL stuff in emulation mode is broken for CUDA 2.2. You would have to use 2.1 for that.

Yes im using that script its really nice thanks for your effort its really nice.

I hope switching back solves my problem.

I’ll post again when i tried it tomorrow.

Thx already!

Thanks alot its working!