Protocol https not supported or disabled in libcurl

Hi I’m working on a project that needs to use roboflow. I’m in the docker container for it and I ran everything normally and even updated/enabled curl on the jetson. So why can’t I use the curl command from roboflow on my jetson? I used the curl command but replaced the url for roboflow with my localhost and when I put in the command it said curl: (1) Protocol " https" not supported or disabled in libcurl


It looks like this issue is related to the curl library.
Could you try to set up curl with ssl and try it again?


It does look like a curl issue, and curl here is just the Ubuntu distribution’s version, but I found something interesting on this: See if your curl supports SSL:
curl --version

If https is not there, then you’ll need the SSL-enabled version. If SSL is available, then you might have quoted your URL wrong…apparently having an extra space in it will cause curl to think it is some other protocol.

The Jetson server serves over http, not https, so you’ll need to update your url to be http

I tried both http and https and nothing worked. But thanks!

Thanks for your response. It seems that my curl version does not support SSL. How can I update it?

If you run the command “which curl”, where does it show up? By default it should be at “/usr/bin/curl”. Next, which package owns this? Use the command “dpkg -S /usr/bin/curl” (or if the file is at a different location, then name that alternate location). By default it should support https. Also, don’t forget what @mo-traor3-ai just mentioned: If the content is served over http and not https, then it won’t matter, so you could skip adding compatibility with https (definitely a good point).

I don’t know why you’d have a version not supporting https, but if a package is not directly available, then you’d have to build it yourself from source.

Everything curl-related is working now; I checked stack overflow and I found out that my problem was that I had an extra space in my command lol! Thank you

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.