--ptxas-options=-v is not working

Hi:)

I’m trying to determine my GPU occupancy, but as you know I need Registers Per Thread and Shared Memory Per Thread Block, but the --ptxas-options=-v command is not giving me any information.

Could it be because I’ve warnings in the code?

I’m using VS2010 and the it is compiling my code with the following command:

1>  F:\Development\Tese\ThesisCudaSimulator>"C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v3.2\bin\nvcc.exe" -gencode=arch=compute_20,code=\"sm_20,compute_20\" --use-local-env --cl-version 2008 -ccbin "C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin\x86_amd64" -I"C:\Program Files\NVIDIA GPU Computing Toolkit\nvToolsExt\include" -I"." -I"C:\ProgramData\NVIDIA Corporation\NVIDIA GPU Computing SDK 3.2\C\common\inc" -I"C:\ProgramData\NVIDIA Corporation\NVIDIA GPU Computing SDK 3.2\C\shared\inc" -I"C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v3.2\include"  -G0  --keep-dir "F:\Development\Tese\ThesisCudaSimulator\obj\x64_Debug_vc100\" -maxrregcount=32 --ptxas-options=-v --machine 64 --compile  -D_NEXUS_DEBUG -g   -D_DEBUG -Xcompiler "/EHsc /nologo /Od /Zi  /MDd " -o "F:\Development\Tese\ThesisCudaSimulator\obj\x64_Debug_vc100\ThesisCudaSimulator.obj" "F:\Development\Tese\ThesisCudaSimulator\ThesisCudaSimulator.cu"

Thank you

Tools/Options -> Projects and Solutions/Build and Run -> MSBuild project build output verbosity
set to: “Normal”