Publish to Project not working

I’m using 3dsMax connector v102.3.0 in max 2022, and Publish to Project is giving me a project path error. It seems to be putting the path in twice.

The project path should be:
omniverse://localhost:3009/Projects/Test/3dsMaxTest.usd

but after I Set Existing View Project, and then click Publish to Project, it’s returning this as my project path: “omniverse://localhost:3009/Projects/Test//localhost/Projects/Test/3dsMaxTest.usd//localhost/Projects/Test/3dsMaxTest.usd

Screenshot 2021-12-01 103118

Is your nucleus and cache also up to date?
We’ll look into this right away, thank you.

I just installed them for the first time, so I think they’re up to date. Is there an easy way to keep them updated to the latest versions?

@user75793 - they don’t auto-update atm. If there’s an update available they’ll have a green bell icon next to them.

User75793,
I just went through a bunch of variations trying to reproduce your issue. It works as expected on my side. In 3dsmax, main menu/omniverse/settings, can you turn on verbose logging. Go through your repro and tell me if any errors or printed to the max script listener?

No errors reported in the listener.

Let’s look at some other things.

  1. When log in to Omniverse, are you just type in “localhost”,then connect. If you already had it like this, skip this step.
  2. When you set a project, you want to point it at a " .project.usd file." which is the actual project file. in your example, 3dsMaxTest.usd looks like it should be a child of a .project.file.

I see there was some confusion on my part between .project.usd and other .usd files. Would it make sense to disable the ability to select non-project USD files in the Set Project browser to avoid this?

Yes, this is something we’ll look into.