Pull access denied for tlt-streamanalytics

Hi,

I’m trying to run samples available in jupyter notebook using following command

docker run --runtime=nvidia -it -v /home/user/tlt-experiments:/workspace/tlt-experiments -p 8888:8888 tlt-streamanalytics:v1.0_py2

Getting the following Error

Unable to find image ‘tlt-streamanalytics:v1.0_py2’ locally
docker: Error response from daemon: pull access denied for tlt-streamanalytics, repository does not exist or may require ‘docker login’: denied: requested access to the resource is denied.

Please download the docker container firstly. See tlt doc https://docs.nvidia.com/metropolis/TLT/tlt-getting-started-guide/index.html#requirements

Execute docker login nvcr.io from the command line and enter your username and password.
Username: $oauthtoken
Password: API_KEY
Execute docker pull nvcr.io/nvidia/tlt-streamanalytics:

Note: API_KEY is exactly your API key.

That’s all done I’m able to run all those commands without error but I’m struck with this error n

Have you downloaded the docker?
$ docker pull nvcr.io/nvidia/tlt-streamanalytics:v1.0_py2

There is error from your log:

Unable to find image 'tlt-streamanalytics:v1.0_py2' locally

So, please check if your docker is available. Could you paste result of below command?
$ docker images |grep tlt

I’m running the above command after pulling the file using

docker pull nvcr.io/nvidia/tlt-streamanalytics:v1.0_py2

I’m able to run following command and get into the container but unable to use jupyter notebook as the ports are not configured

docker run --runtime=nvidia -it -v /home//tlt-experiments:/workspace/tlt-experiments nvcr.io/nvidia/tlt-streamanalytics: /bin/bash

See tlt doc

Go to the examples folder: cd examples/

Execute this command from inside the docker to start the jupyter notebook:

jupyter notebook --ip 0.0.0.0 --allow-root
Copy and paste the link produced from this command into your browser to access the notebook.

I’m getting the following output

nvcr.io/nvidia/tlt-streamanalytics v1.0_py2 7d6e4b479f7b 5 weeks ago 7.82GB

I followed the steps and got the below link generated but my browser(Firefox) is Unable to Connect
and Site Can’t be reached in Chrome
http://127.0.0.1:8888/?token=207501f8b992b95634cf7748491ec029441737af8066236d

Your step should work well. Please re-try again.

Tried again. Struck here since yesterday.

Is there any other way I can do something

I tried the following command which worked for me without errors or permission issues

docker run --runtime=nvidia -it -v /home/user/tlt-experiments:/workspace/tlt-experiments -p 8888:8888 nvcr.io/nvidia/tlt-streamanalytics:v1.0_py2 /bin/bash

instead of the following command given in the documentation

docker run --runtime=nvidia -it -v /home/user/tlt-experiments:/workspace/tlt-experiments -p 8888:8888 tlt-streamanalytics:v1.0_py2

Thanks for your Support @Morganh