Putting TX2i into Recovery Mode.

I’m having a lot of difficultly putting a TX2i into recovery mode in order to flash a new image. I’ve been able to do it many times with a TK1, TX1, and TX2. When I power on the development board the power LED and recovery LED come on instantly. I’ve tried many combination of holding buttons while plugging in the power cable. No luck. Also, I’m seeing Nvidia Corp. in ‘lsusb’ all the time. Even on a fresh boot. This seems much different from legacy versions. I’ve tried two different TX2i’s, JetPack 3.3 and 3.2.1. And different cables. Tomorrow I’ll try a different development board. Has anyone been able to successfully flash a TX2i???

I haven’t worked with the TX2i, but beware that if you purchase a module separately (not as a dev kit with a carrier board), then no software or o/s is installed. It might be that you have to start by flashing and there is no other possibility (meaning if the lsusb on the host shows the device you are good to flash and it may be this is always how a blank unit starts…not sure).

Hi manicely6005,

Put the TX2i into reocvery mode steps is the same with TX1/TX2/TK1:
–> Holding down the RECOVERY button and press POWER button once on the main board.
Please try to press POWER button a litter longer till LED light up, then check your device via lsusb.

Hello,
I have the same problem. I have my own design for carrier board. TX2 gets into USB recovery mode by shorting the FORCE_RECOV# to GND and powering up the system. However when I use TX2i I cannot get into USB recovery mode in the same scenarioo.
I want to mention that I work in Auto-Power-On on my carrier so CHARGER PRSNT (pin A49) is connected to GND for TX2 and POWER BTN (pin B50) is floating for TX2i Auto-Power-On.

Am I missing soething here?