PWM and interrupts not working together

Hi team,

I am facing a strange issue when trying to run a python script with interrupts and pwm being initialised. The interrupts are being used to keep track of a rotary encoder and the pwm to control a motor.

If I run the script with both the interrupts and pwm set up (using jetson.GPIO), the interrupts no longer work once I start the pwm. I’ve tested and both the interrupts and pwm work if I run them in separately, but as soon as i try to use both the interrupts no longer function. Does anyone know what is causing this issue and how I can fix it?

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.

hello amaanv_uct,

may I know which pins you’re used for testing? please also review the Jetson.GPIO, had you setup the pin correctly?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.