PWM-FAN pin is not working on Jetson TX2

pwm-fan pin that is GPIO_SEN6 in pinmux sheet.

My fan is auto roating during bootup. At UBOOT when i am reading that pin i
am getting these pin as input but it is declared output pin in pinmux sheet.

Tegra186 (P2771-0000-500) # gpio status -a V6
Bank V:
V6: input: 0

why this pin is coming input,these PWM pin should be out same is declared in pinmux sheet.

Any help will be appreciated.

hello anupam.kumar,

is your fan rotated with the following command?
i.e. $ sudo /usr/bin/jetson_clocks --fan

using these command i am also able to rotate the fan…now what i am doing is after bootup i am setting target_pwm to rotate the fan…

so my fan is connected to gpio expander which i am enabling and disabling it during bootup but during boot this fans runs automatically and after login console it stops and when i set target pwm it rotate.

so my question is why this fan is rotating during MB1 and MB2 load,i want to handle target-pwm in uboot to not roatate,can we do that??

pwm-fan is output pin,right?but in UBOOT it is showing input pin and i amnot able to make these pin as output

hello anupam.kumar,

please configure target_pwm to make it works.
you may also check Read fan frequency from FAN_TACH signal for reference,
thanks

see by setting target_pwm , it is working fine,but issue is that during reboot fan is moving so my question is that in nvidia binary like MB1 and MB2,this fan-pwm pin is enabled,right?

can you confirm this?

hello anupam.kumar,

we had checked this, the fan did not rotate during boot-up stage on Jetson-TX2 devkits.

but with custom board it is happening,do we need to change anything for this.

we have kept same pin for fan-pwm and tach pin that is mention in pinmux sheet…do we need to take care anything for this…?

in my case before uboot fan is moving…so we dont have control over MB1 and MB2 binary…how we can disable it…fan-pwm pin is output or input pin?

hello anupam.kumar,

please also share console logs to obtain MB1, MB2, CBoot, and UBoot for reference,
thanks

please get the logs:

Last login: Sun Jan 28 15:58:30 UTC 2018 on ttyS0
Welcome to Ubuntu 18.04.4 LTS (GNU/Linux 4.9.140 aarch64)
root@localhost:/home/ubuntu#
root@localhost:/home/ubuntu#
root@localhost:/home/ubuntu#
root@localhost:/home/ubuntu#
root@localhost:/home/ubuntu#
root@localhost:/home/ubuntu# ls
Desktop examples.desktop
root@localhost:/home/ubuntu#
root@localhost:/home/ubuntu#
root@localhost:/home/ubuntu#
root@localhost:/home/ubuntu# reboot

Ses[ 878.046106] watchdog: watchdog0: watchdog did not stop!
[ 878.055455] systemd-shutdow: 41 output lines suppressed due to ratelimiting
[ 878.386126] tegra-xusb 3530000.xhci: Host not halted after 16000 microseconds.
[ 878.426373] reboot: Restarting system
[0000.049] C> I2C command failed
[0000.052] C> block index = (4) and rail_id = (1)
[0000.057] C> Addr: Reg = [0xe8:0x07]: 336166925
[0000.061] C> I2C command failed
[0000.064] C> block index = (5) and rail_id = (1)
[0000.069] C> Addr: Reg = [0xe8:0x07]: 336166925
[0000.170] I> Welcome to MB2(TBoot-BPMP)(version: 01.00.160913-t186-M-00.00-mobile-c700205d)
[0000.179] I> bit @ 0xd480000
[0000.182] I> Boot-device: eMMC
[0000.189] I> sdmmc bdev is already initialized
[0000.194] I> pmic: reset reason (nverc) : 0x0
[0000.214] W> Cannot find any partition table for 00000003
[0000.233] I> Found 34 partitions in SDMMC_USER (instance 3)
[0000.239] W> No valid slot number is found in scratch register
[0000.245] W> Return default slot: _a
[0000.248] I> A/B: bin_type (16) slot 0
[0000.252] I> Loading partition bpmp-fw at 0xd7800000
[0000.257] I> Reading two headers - addr:0xd7800000 blocks:1
[0000.262] I> Addr: 0xd7800000, start-block: 13369352, num_blocks: 1
[0000.287] I> Binary(16) of size 533504 is loaded @ 0xd7800000
[0000.293] W> No valid slot number is found in scratch register
[0000.298] W> Return default slot: _a
[0000.302] I> A/B: bin_type (17) slot 0
[0000.305] I> Loading partition bpmp-fw-dtb at 0xd79f0000
[0000.310] I> Reading two headers - addr:0xd79f0000 blocks:1
[0000.316] I> Addr: 0xd79f0000, start-block: 13371768, num_blocks: 1
[0000.337] I> Binary(17) of size 314992 is loaded @ 0xd79b3000
[0000.460] I> Loading SCE-FW …
[0000.463] W> No valid slot number is found in scratch register
[0000.469] W> Return default slot: _a
[0000.472] I> A/B: bin_type (12) slot 0
[0000.476] I> Loading partition sce-fw at 0xd7300000
[0000.481] I> Reading two headers - addr:0xd7300000 blocks:1
[0000.486] I> Addr: 0xd7300000, start-block: 13375864, num_blocks: 1
[0000.505] I> Binary(12) of size 125168 is loaded @ 0xd7300000
[0000.511] I> Init SCE
[0000.513] I> Loading APE-FW …
[0000.516] W> No valid slot number is found in scratch register
[0000.522] W> Return default slot: _a
[0000.525] I> A/B: bin_type (11) slot 0
[0000.529] I> Loading partition adsp-fw at 0xd7400000
[0000.534] I> Reading two headers - addr:0xd7400000 blocks:1
[0000.539] I> Addr: 0xd7400000, start-block: 13352968, num_blocks: 1
[0000.558] I> Binary(11) of size 107808 is loaded @ 0xd7400000
[0000.564] I> Copy BTCM section
[0000.567] W> No valid slot number is found in scratch register
[0000.573] W> Return default slot: _a
[0000.576] I> A/B: bin_type (13) slot 0
[0000.580] I> Loading partition cpu-bootloader at 0x96000000
[0000.585] I> Reading two headers - addr:0x96000000 blocks:1
[0000.591] I> Addr: 0x96000000, start-block: 13332488, num_blocks: 1
[0000.611] I> Binary(13) of size 284816 is loaded @ 0x96000000
[0000.617] W> No valid slot number is found in scratch register
[0000.623] W> Return default slot: _a
[0000.626] I> A/B: bin_type (20) slot 0
[0000.630] I> Loading partition bootloader-dtb at 0x8520f400
[0000.635] I> Reading two headers - addr:0x8520f400 blocks:1
[0000.641] I> Addr: 0x8520f400, start-block: 13334536, num_blocks: 1
[0000.661] I> Binary(20) of size 253872 is loaded @ 0x8520f400
[0000.667] W> No valid slot number is found in scratch register
[0000.672] W> Return default slot: _a
[0000.676] I> A/B: bin_type (14) slot 0
[0000.679] I> Loading partition secure-os at 0x8530f600
[0000.684] I> Reading two headers - addr:0x8530f600 blocks:1
[0000.690] I> Addr: 0x8530f600, start-block: 13336584, num_blocks: 1
[0000.712] I> Binary(14) of size 366000 is loaded @ 0x8530f600
[0000.720] I> TOS boot-params @ 0x85000000
[0000.724] I> TOS params prepared
[0000.727] I> Loading EKS …
[0000.729] I> A/B: bin_type (15) slot 0
[0000.733] I> Loading partition eks at 0x8590f800
[0000.738] I> Reading two headers - addr:0x8590f800 blocks:1
[0000.743] I> Addr: 0x8590f800, start-block: 13348872, num_blocks: 1
[0000.762] I> Binary(15) of size 1040 is loaded @ 0x8590f800
[0000.767] I> EKB detected (length: 0x400) @ 0x8590f800
[0000.772] I> Copied encrypted keys
[0000.776] I> boot profiler @ 0x175844000
[0000.780] I> boot profiler for TOS @ 0x175844000
[0000.785] I> Unhalting SCE
[0000.787] I> Primary Memory Start:80000000 Size:70000000
[0000.792] I> Extended Memory Start:f0110000 Size:856f0000
[0000.799] I> MB2(TBoot-BPMP) done

NOTICE: BL31: v1.3(release):41d46a9cf
NOTICE: BL31: Built : 21:14:44, Jun 25 2020
ipc-unittest-main: 1519: Welcome to IPC unittest!!!
ipc-unittest-main: 1531: waiting forever
ipc-unittest-srv: 329: Init unittest services!!!
hwkey-agent: 40: hwkey-agent is running!!
hwkey-agent: 182: key_mgnt_processing …
hwkey-agent: 157: Init hweky-agent services!!
platform_bootstrap_epilog: trusty bootstrap complete
[0001.105] I> Welcome to Cboot
[0001.108] I> Cboot Version: t186-02737b3e
[0001.112] I> CPU-BL Params @ 0x175800000
[0001.115] I> 0) Base:0x00000000 Size:0x00000000
[0001.120] I> 1) Base:0x177f00000 Size:0x00100000
[0001.124] I> 2) Base:0x177e00000 Size:0x00100000
[0001.129] I> 3) Base:0x177d00000 Size:0x00100000
[0001.133] I> 4) Base:0x177c00000 Size:0x00100000
[0001.138] I> 5) Base:0x177b00000 Size:0x00100000
[0001.142] I> 6) Base:0x177800000 Size:0x00200000
[0001.147] I> 7) Base:0x177400000 Size:0x00400000
[0001.152] I> 8) Base:0x177a00000 Size:0x00100000
[0001.156] I> 9) Base:0x177300000 Size:0x00100000
[0001.161] I> 10) Base:0x176800000 Size:0x00800000
[0001.165] I> 11) Base:0x30000000 Size:0x00040000
[0001.169] I> 12) Base:0xf0000000 Size:0x00100000
[0001.174] I> 13) Base:0x30040000 Size:0x00001000
[0001.178] I> 14) Base:0x30048000 Size:0x00001000
[0001.183] I> 15) Base:0x30049000 Size:0x00001000
[0001.187] I> 16) Base:0x3004a000 Size:0x00001000
[0001.192] I> 17) Base:0x3004b000 Size:0x00001000
[0001.196] I> 18) Base:0x3004c000 Size:0x00001000
[0001.201] I> 19) Base:0x3004d000 Size:0x00001000
[0001.205] I> 20) Base:0x3004e000 Size:0x00001000
[0001.209] I> 21) Base:0x3004f000 Size:0x00001000
[0001.214] I> 22) Base:0x00000000 Size:0x00000000
[0001.218] I> 23) Base:0xf0100000 Size:0x00010000
[0001.223] I> 24) Base:0x00000000 Size:0x00000000
[0001.227] I> 25) Base:0x00000000 Size:0x00000000
[0001.232] I> 26) Base:0x00000000 Size:0x00000000
[0001.236] I> 27) Base:0x00000000 Size:0x00000000
[0001.240] I> 28) Base:0x84400000 Size:0x00400000
[0001.245] I> 29) Base:0x30000000 Size:0x00010000
[0001.249] I> 30) Base:0x178000000 Size:0x08000000
[0001.254] I> 31) Base:0x00000000 Size:0x00000000
[0001.258] I> 32) Base:0x176000000 Size:0x00600000
[0001.263] I> 33) Base:0x80000000 Size:0x70000000
[0001.267] I> 34) Base:0xf0110000 Size:0x856f0000
[0001.272] I> 35) Base:0x00000000 Size:0x00000000
[0001.276] I> 36) Base:0x00000000 Size:0x00000000
[0001.280] I> 37) Base:0x1772e0000 Size:0x00020000
[0001.285] I> 38) Base:0x84000000 Size:0x00400000
[0001.289] I> 39) Base:0x96000000 Size:0x02000000
[0001.294] I> 40) Base:0x85000000 Size:0x01200000
[0001.298] I> 41) Base:0x175800000 Size:0x00500000
[0001.303] I> 42) Base:0x00000000 Size:0x00000000
[0001.307] I> 43) Base:0x00000000 Size:0x00000000
[0001.312] GIC-SPI Target CPU: 4
[0001.315] Interrupts Init done
[0001.318] calling constructors
[0001.321] initializing heap
[0001.324] initializing threads
[0001.327] initializing timers
[0001.330] creating bootstrap completion thread
[0001.335] top of bootstrap2()
[0001.338] CPU: ARM Cortex A57
[0001.341] CPU: MIDR: 0x411FD073, MPIDR: 0x80000100
[0001.346] initializing platform
[0001.350] I> Bl_dtb @0x8520f400
[0001.353] I> gpio framework initialized
[0001.358] I> tegrabl_gpio_driver_register: register ‘nvidia,tegra186-gpio’ driver
[0001.367] I> tegrabl_gpio_driver_register: register ‘nvidia,tegra186-gpio-aon’ driver
[0001.375] I> GPIO framework and drivers are initialized.
[0001.380] I> Boot-device: eMMC
[0001.387] I> sdmmc bdev is already initialized
[0001.407] W> Cannot find any partition table for 00000003
[0001.425] I> Found 34 partitions in SDMMC_USER (instance 3)
[0001.430] W> opt-in fuse is not set, skip fuse_burning
[0001.435] I> Reserved memory at 0xfbe00000 for U-Boot relocation
[0001.441] W> No valid slot number is found in scratch register
[0001.447] W> Return default slot: _a
[0001.450] I> A/B: bin_type (21) slot 0
[0001.453] I> Loading kernel-dtb from partition
[0001.458] I> Loading partition kernel-dtb at 0x80000000 from device(0x1)
[0001.475] I> Kernel_dtb @0x80000000
[0001.478] I> tegrabl_tca9539_init: i2c bus: 0, slave addr: 0xee
[0001.486] E> I2C: slave not found in slaves.
[0001.490] E> I2C: Could not write 0 bytes to slave: 0x00ee with repeat start false.
[0001.498] E> I2C_DEV: Failed to send register address 0x00000004.
[0001.504] E> I2C_DEV: Could not write 1 registers of size 1 to slave 0xee at 0x00000004 via instance 0.
[0001.513] E> tca9539_device_init: failed to write polar reg
[0001.519] E> tegrabl_tca9539_init: failed to init device!
[0001.524] I> tegrabl_tca9539_init: i2c bus: 0, slave addr: 0xe8
[0001.530] E> I2C: slave not found in slaves.
[0001.535] E> I2C: Could not write 0 bytes to slave: 0x00e8 with repeat start false.
[0001.542] E> I2C_DEV: Failed to send register address 0x00000004.
[0001.548] E> I2C_DEV: Could not write 1 registers of size 1 to slave 0xe8 at 0x00000004 via instance 0.
[0001.557] E> tca9539_device_init: failed to write polar reg
[0001.563] E> tegrabl_tca9539_init: failed to init device!
[0001.570] I> fixed regulator driver initialized
[0001.597] I> register ‘maxim’ power off handle
[0001.602] I> virtual i2c enabled
[0001.605] I> registered ‘maxim,max77620’ pmic
[0001.609] I> tegrabl_gpio_driver_register: register ‘max77620-gpio’ driver
[0001.619] I> Find /i2c@c250000’s alias i2c7
[0001.623] I> Reading eeprom i2c=7 address=0x50
[0001.653] I> Device at /i2c@c250000:0x50
[0001.656] I> Reading eeprom i2c=7 address=0x57
[0001.661] E> I2C: slave not found in slaves.
[0001.665] E> I2C: Could not write 0 bytes to slave: 0x00ae with repeat start true.
[0001.673] E> I2C_DEV: Failed to send register address 0x00000000.
[0001.679] E> I2C_DEV: Could not read 256 registers of size 1 from slave 0xae at 0x00000000 via instance 7.
[0001.688] E> eeprom: Failed to read I2C slave device
[0001.693] I> Eeprom read failed 0x3526070d
[0001.697] I> Find /i2c@c240000’s alias i2c1
[0001.701] I> Reading eeprom i2c=1 address=0x51
[0001.707] E> I2C: slave not found in slaves.
[0001.711] E> I2C: Could not write 0 bytes to slave: 0x00a2 with repeat start true.
[0001.718] E> I2C_DEV: Failed to send register address 0x00000000.
[0001.724] E> I2C_DEV: Could not read 256 registers of size 1 from slave 0xa2 at 0x00000000 via instance 1.
[0001.734] E> eeprom: Retry to read I2C slave device.
[0001.739] E> I2C: slave not found in slaves.
[0001.743] E> I2C: Could not write 0 bytes to slave: 0x00a2 with repeat start true.
[0001.750] E> I2C_DEV: Failed to send register address 0x00000000.
[0001.756] E> I2C_DEV: Could not read 256 registers of size 1 from slave 0xa2 at 0x00000000 via instance 1.
[0001.766] E> eeprom: Failed to read I2C slave device
[0001.771] I> Eeprom read failed 0x3526070d
[0001.775] I> Find /i2c@3160000’s alias i2c0
[0001.779] I> Reading eeprom i2c=0 address=0x50
[0001.808] I> Device at /i2c@3160000:0x50
[0001.812] I> Find /i2c@3180000’s alias i2c2
[0001.816] I> Reading eeprom i2c=2 address=0x54
[0001.821] I> Enabling gpio chip_id = 2, gpio pin = 9
[0001.825] C> GPIO driver for chip_id 0x2 could not be found
[0001.831] E> cam_eeprom_read: Can’t get gpio driver
[0001.835] I> Eeprom read failed 0x4d4d000d
[0001.839] I> Reading eeprom i2c=2 address=0x57
[0001.844] I> Enabling gpio chip_id = 2, gpio pin = 9
[0001.848] C> GPIO driver for chip_id 0x2 could not be found
[0001.854] E> cam_eeprom_read: Can’t get gpio driver
[0001.858] I> Eeprom read failed 0x4d4d000d
[0001.862] I> create_pm_ids: id: 3489-0888-300-J, len: 15
[0001.867] I> config: mem-type:00,power-config:00,misc-config:00,modem-config:00,touch-config:00,display-config:00, len: 93
[0001.878] I> create_pm_ids: id: XXXX-XXXX-XXX-X, len: 15
[0001.883] I> config: mem-type:ff,power-config:ff,misc-config:ff,modem-config:ff,touch-config:ff,display-config:ff, len: 93
[0001.902] E> cannot find any other nvdisp nodes
[0001.906] E> no valid display unit config found in dtb
[0001.912] W> display init failed
[0001.915] initializing target
[0001.918] calling apps_init()
[0001.921] starting app kernel_boot_app
[0001.944] I> found decompressor handler: lz4-legacy
[0001.948] I> decompressing BMP blob …
[0001.958] I> Kernel type = Normal
[0001.962] I> Loading kernel-bootctrl from partition
[0001.966] I> Loading partition kernel-bootctrl at 0xa8000000 from device(0x1)
[0001.980] W> tegrabl_get_kernel_bootctrl: magic number(0x00000000) is invalid
[0001.987] W> tegrabl_get_kernel_bootctrl: use default dummy boot control data
[0001.994] I> ########## Fixed storage boot ##########
[0001.999] W> No valid slot number is found in scratch register
[0002.005] W> Return default slot: _a
[0002.008] I> A/B: bin_type (24) slot 0
[0002.024] I> Boot image size read from image header: 75402
[0002.029] I> Boot image load address: 0x80400000
[0002.033] I> Loading kernel from partition
[0002.037] I> Loading partition kernel at 0x80400000 from device(0x1)
[0002.981] I> Validate kernel …
[0002.984] I> T18x: Authenticate kernel (bin_type 24), max size 0x4000000
[0002.991] I> kernel-dtb is already loaded
[0002.995] I> Validate kernel-dtb …
[0002.998] I> T18x: Authenticate kernel-dtb (bin_type 21), max size 0x100000
[0003.006] I> Checking boot.img header magic … [0003.010] I> [OK]
[0003.012] I> Kernel hdr @0x80400000
[0003.015] I> Kernel dtb @0x80000000
[0003.018] I> decompressor handler not found
[0003.022] I> Copying kernel image (480258 bytes) from 0x80400800 to 0x80600000 … [0003.030] I> Done
[0003.032] I> Move ramdisk (len: 0) from 0x80476000 to 0x947b0000
[0003.039] I> Updated bpmp info to DTB
[0003.044] I> Ramdisk: Base: 0x947b0000; Size: 0x0
[0003.048] I> Updated initrd info to DTB
[0003.052] W> WARN: Fail to override “console=none” in commandline
[0003.058] E> tegrabl_linuxboot_add_disp_param, du 0 failed to get display params
[0003.065] E> tegrabl_linuxboot_add_disp_param, du 0 failed to get display params
[0003.072] E> tegrabl_linuxboot_add_disp_param, du 0 failed to get display params
[0003.079] I> disabled_core_mask: 0xffffff0c
[0003.083] W> No valid slot number is found in scratch register
[0003.089] W> Return default slot: _a
[0003.092] I> Active slot suffix:
[0003.095] I> add_boot_slot_suffix: slot_suffix =
[0003.100] I> Linux Cmdline: console=ttyS0,115200 androidboot.presilicon=true firmware_class.path=/etc/firmware root=/dev/mmcblk0p1 rw rootwai
[0003.145] I> Updated bootarg info to DTB
[0003.149] W> MAC addr invalid!
[0003.152] E> Failed to get WIFI MAC address
[0003.156] W> MAC addr invalid!
[0003.158] E> Failed to get Bluetooth MAC address
[0003.163] I> eeprom_get_mac_addr: MAC (type: 2): 00:04:4b:cc:42:f0
[0003.169] E> Found no plugin manager ids in source DT
[0003.174] W> Add plugin manager ids from board info
[0003.179] W> “plugin-manager” doesn’t exist, creating
[0003.184] W> “ids” doesn’t exist, creating
[0003.188] W> “connection” doesn’t exist, creating
[0003.192] W> “configs” doesn’t exist, creating
[0003.196] I> create_pm_ids: id: 3489-0888-300-J, len: 15
[0003.202] I> config: mem-type:00,power-config:00,misc-config:00,modem-config:00,touch-config:00,display-config:00, len: 93
[0003.212] I> create_pm_ids: id: XXXX-XXXX-XXX-X, len: 15
[0003.218] I> config: mem-type:ff,power-config:ff,misc-config:ff,modem-config:ff,touch-config:ff,display-config:ff, len: 93
[0003.229] I> Adding plugin-manager/ids/3489-0888-300=/i2c@c250000:module@0x50
[0003.236] W> “i2c@c250000” doesn’t exist, creating
[0003.240] W> “module@0x50” doesn’t exist, creating
[0003.245] I> Adding plugin-manager/ids/XXXX-XXXX-XXX=/i2c@3160000:module@0x50
[0003.252] W> “i2c@3160000” doesn’t exist, creating
[0003.257] W> “module@0x50” doesn’t exist, creating
[0003.263] I> Adding plugin-manager/ids/3489-0888-300-J
[0003.269] I> Adding plugin-manager/configs/3489-mem-type 00
[0003.275] I> Adding plugin-manager/configs/3489-power-config 00
[0003.281] I> Adding plugin-manager/configs/3489-misc-config 00
[0003.287] I> Adding plugin-manager/configs/3489-modem-config 00
[0003.293] I> Adding plugin-manager/configs/3489-touch-config 00
[0003.298] I> Adding plugin-manager/configs/3489-display-config 00
[0003.305] I> Adding plugin-manager/cvm
[0003.308] W> “chip-id” doesn’t exist, creating
[0003.313] I> Adding plugin-manager/chip-id/A02P
[0003.317] W> “odm-data” doesn’t exist, creating
[0003.322] I> Adding /chosen/plugin-manager/odm-data
[0003.330] I> added [base:0x80000000, size:0x70000000] to /memory
[0003.336] I> added [base:0xf0200000, size:0x85600000] to /memory
[0003.342] I> added [base:0x175e00000, size:0x200000] to /memory
[0003.348] I> added [base:0x176600000, size:0x200000] to /memory
[0003.353] I> added [base:0x177000000, size:0x200000] to /memory
[0003.359] I> Updated memory info to DTB
[0003.363] E> add_disp_param: failed to get display params for du=0
[0003.371] W> “reset” doesn’t exist, creating
[0003.375] W> “pmc-reset-reason” doesn’t exist, creating
[0003.380] W> “pmic-reset-reason” doesn’t exist, creating
[0003.386] I> Adding ecid(00000001645cc4002000000005058380) to DT
[0003.392] I> disabled_core_mask: 0xffffff0c
[0003.402] I> Add serial number:1422419138473 as DT property
[0003.409] I> Plugin-manager override starting
[0003.415] I> node /plugin-manager/fragement@0 matches
[0003.423] I> node /plugin-manager/fragement@4 matches
[0003.447] I> Disable plugin-manager status in FDT
[0003.452] I> Plugin-manager override finished successfully
[0003.457] I> tegrabl_load_kernel_and_dtb: Done
[0003.462] E> tegrabl_display_clear: display is not initialized
[0003.467] W> Boot logo display failed…
[0003.471] I> Kernel EP: 0x80600000, DTB: 0x80000000

U-Boot 2016.07 (Jan 21 2021 - 12:42:34 +0530)Version:1.3.0.0

TEGRA186
Model: NVIDIA P2771-0000-500
DRAM: 3.8 GiB
MMC: Tegra SD/MMC: 0, Tegra SD/MMC: 1
In: serial
Out: serial
Err: serial
Net: eth0: ethernet@2490000
Writing to MMC(0)… done
Writing to MMC(0)… done
Writing to MMC(0)… done
BOOT_REASON:SW_REBOOT
TESt:BOOT_REASON:SW_REBOOT
Writing to MMC(0)… done
Writing to MMC(0)… done
Hit any key to stop autoboot: 0
Retrieving file: /boot/extlinux/extlinux_pri.conf
350 bytes read in 154 ms (2 KiB/s)
1: primary kernel
Retrieving file: /boot/initrd
5565615 bytes read in 270 ms (19.7 MiB/s)
Retrieving file: /boot/Image
34267144 bytes read in 855 ms (38.2 MiB/s)
append: console=ttyS0,115200 androidboot.presilicon=true firmware_class.path=/etc/firmware root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 con

Flattened Device Tree blob at 80000000

Booting using the fdt blob at 0x80000000
reserving fdt memory region: addr=80000000 size=10000
Using Device Tree in place at 0000000080000000, end 0000000080042f48

also when i running reboot command ,fan is moving till cboot and on uboot we are disabling fan gpio to stop moving fan.

I probed the pwm-fan pin it is going low during MB1,MB2,cboot boot and here fan is moving…how we can stop this or it is deafult behaviour?

hello anupam.kumar,

please check your pinmux configuration files, for your reference, here’s TX2’s default gpio_sen6_pv6 settings ,
thanks

pinmux.0x0c302078 = 0x00000401; # gpio_sen6_pv6: gp, tristate-disable, input-disable, lpdr-disable

I checked my pinmux cfg file for gpio_sen6_pv6 pin setting… it is same as default which you have mention.

so what these setting tells,will pwm-fan is output with zero value or it is input pin…?

do we need to change these default value out fan is moving in MB1 amd MB2 running and when i probe it i am getting pwm-fan pin value is zero…

FAN is on CVM and you are using the CVM as it is, right?
Or in your system, you have connected your fan from a 40 pin connector?

can you please tell,what is CVM?

Fan connections are same as TX2 EVK in our custom board…

Jetson TX2 devkit is a combination of 3310 Computer Vison Module and 2597 base board. You must have replaced 2597 board and used your custom board?
Or?

1 Like

Hi anupam,
pinmux.0x0c302078 = 0x00000401; # gpio_sen6_pv6: gp, tristate-disable, input-disable, lpdr-disable
This means FAN_PWM pin is used with “pwm” functionality not as gpio as bit 10 is set and input is disabled means default diection is set as output.
When you are reading from uboot shell, you are checking gpio controller status.
If in pinmux, pin is not set to gpio, then gpio controller will give default status as input.

Hi shgarg,

if i see my board and grep this register

root@localhost:/home/ubuntu# cat /sys/kernel/debug/tegra_pinctrl_reg | grep sen6
Bank: 1 Reg: 0x0c302078 Val: 0x00000401 → gpio_sen6_pv6
root@localhost:/home/ubuntu#

so this setting is fine in my board but this pin is output in pinmux sheet but its value is not declared is it output with low value or output with high value.??

whenever i am rebooting my board during MB1,MB2 and cboot this fan is moving…so it is default behaviour or it should not rotate during boot but after kernel bootup this pwm-fan pin is handled by device tree so this rotation goes off after kernel up.

can you please clarify this.