PWM is not working normally

Hello, everyone:
I used NX output PWM to fan, the same config as the original carrier board. tegra_pwm6 GPIO14(PH.01), but when i used the command cat /sys/kernel/debug/pwm, it show

platform/32d0000.pwm, 1 PWM device
 pwm-0   (pwm-fan             ): requested enabled period: 45334 ns duty: 0 ns polarity: normal

and the sound of the fan is very large.
So what should i do next? thank you.

best reagrds,
ultwcz1997

hello ultwcz1997,

may I know which JetPack release version you’re working with,

are you running heavy loaded program?
what’s the thermal condition, please also enable $ sudo tegrastats to gather processor reports.
besides, could you please refer to developer guide for Fan Speed Control.
thanks

Hi, JerryChang,
Thank you reply. I am so sorry to reply slowly.

1.may I know which JetPack release version you’re working with?

Jepack4.4 R32.4.3

2.are you running heavily loaded program?

maybe, i will try to disable some processes.

3. $ sudo tegrastats

RAM 3682/7771MB (lfb 884x4MB) SWAP 0/3886MB (cached 0MB) CPU [22%@1420,26%@1420,25%@1420,26%@1420,26%@1420,30%@1420] EMC_FREQ 9%@1600 GR3D_FREQ 78%@1109 APE 150 MTS fg 0% bg 15% AO@27C GPU@29C PMIC@100C AUX@28C CPU@30C thermal@28.75C VDD_IN 6560/6560 VDD_CPU_GPU_CV 2640/2640 VDD_SOC 1357/1357

RAM 3683/7771MB (lfb 884x4MB) SWAP 0/3886MB (cached 0MB) CPU [25%@1420,25%@1420,21%@1420,24%@1420,25%@1420,25%@1420] EMC_FREQ 9%@1600 GR3D_FREQ 0%@1109 APE 150 MTS fg 0% bg 12% AO@27C GPU@29C PMIC@100C AUX@28C CPU@29.5C thermal@28.75C VDD_IN 6400/6480 VDD_CPU_GPU_CV 2520/2580 VDD_SOC 1317/1337

RAM 3683/7771MB (lfb 884x4MB) SWAP 0/3886MB (cached 0MB) CPU [23%@1420,21%@1420,26%@1420,28%@1420,27%@1420,22%@1420] EMC_FREQ 9%@1600 GR3D_FREQ 0%@1109 APE 150 MTS fg 0% bg 13% AO@27C GPU@29C PMIC@100C AUX@28C CPU@29.5C thermal@28.95C VDD_IN 6360/6440 VDD_CPU_GPU_CV 2480/2546 VDD_SOC 1317/1330

RAM 3684/7771MB (lfb 884x4MB) SWAP 0/3886MB (cached 0MB) CPU [25%@1420,25%@1420,27%@1420,21%@1420,23%@1420,27%@1420] EMC_FREQ 9%@1600 GR3D_FREQ 0%@1109 APE 150 MTS fg 0% bg 14% AO@27C GPU@29C PMIC@100C AUX@28C CPU@29.5C thermal@28.75C VDD_IN 6320/6410 VDD_CPU_GPU_CV 2480/2530 VDD_SOC 1317/1327

The main problem is the sound of the fan is large when i boot at first.

hello ultwcz1997,

fan is setting to full speed while system boot-up, it should behavior normally after you enter ubuntu desktop.
you may see-also Maximizing Jetson Nano or Jetson TX1 Performance, if you running jetson_clocks script to maximize Jetson Nano performance by adding --fan options. it’ll also set the maximum PWM fan speed.

Ok, thank you.