PWM on Jetson Nano : weird output


I’ve been trying to get the PWMs outputs of the Jetson Nano to work lately but I didn’t succeed.
I used the script (which is presented here to set the 32 and 33 pins of the 40-pin header to output PWM.
I also use the Jetson.GPIO python library and the sample to test everything.

In fact, When I run the script I do have an output that might look like PWM from very far away but that is absolutely not suitable for servos.

Here is the output on an oscilloscope : and the “rectangles” that you can see on top of the signal, do look like a PWM output as they have the right duty cycle that I provided and the right frequency of 50 Hz but I can’t do anything with it…

My oscillo is wired between one ground pin of the header and the 33 pin (it is the same with the 32 pin)

Do any of you have any idea of what I am doing wrong ?

hello Soudini,

please download Jetson Nano Pinmux spreadsheet to have customization, please configure GPIO_PE6 and LCD_BL_PWM as PWM.
you might also access Jetson Nano Developer Kit 40-Pin Expansion Header Configuration through download center for the application notes.


Thank you for your answer. I tried a few days back this method using the same tutorial as the one you sent me but I only managed to break the card and I had to reflash it make it works again (it wouldn’t boot after the reconfiguring).

As such, I wanted to try a different approach and the doc says to use the script to configure the GPIO, here is its output Isn’t this sufficient ?

1 Like

hello Soudini,

yes, we had release Jetson-IO python script since l4t-r32.3.1, Jetpack-4.3
you’re able to configure 40-pin pinout of Nano J41 with that script file.

Hi @Soudini,

I would like to hear the updates on this post.

Did you manage to fix the issue?


Yes, I managed to fix the issue but it was more a workaround than a fix. I needed 2 PWM outputs to control 2 motors and as I couldn’t manage to get any of the integrated ones to work, I used a PCA9685 board which allow to use 16 PWM outputs from one I2C interface of the Jetson Nano which worked perfectly fine with python.

If you have any more questions I’ll gladly answer them ! And if you have an idea of how I could have fixed the issue, I’m curious. I don’t have a board with me anymore though…