PWM on Jetson Nano with Jetpack 4.3

I am trying to get PWM working on my Jetson Nano under Jetpack 4.3. I am using physical pin 33, and grounded through physical pin 9. In running the NVIDIA sample code found here:

I get no errors, but on the scope, I see no indication of PWM.

I then tried this very simple example from the python3 shell:
‘’’
sudo python3
Python 3.6.9 (default, Apr 18 2020, 01:56:04)
[GCC 8.4.0] on linux
Type “help”, “copyright”, “credits” or “license” for more information.

import RPi.GPIO as GPIO
GPIO.setmode(GPIO.BOARD)
GPIO.setup(33,GPIO.OUT)
my_pwm=GPIO.PWM(33,100)
my_pwm.start(50)
‘’’
Again, no errors, but no PWM on the scope and no voltage on a volt meter.

Any help would be greatly appreciated.
Paul McWhorter
toptechboy.com

hello paul.mcwhorter,

according to Nano’s pinmux spreadsheets, pin-33 (GPIO_PE6) has configure as GPIO pin by default.
please refer to documentation, Configuring the 40-Pin Expansion Header chapter to update board configuration for pin customization.
thanks

You need to enable the PWM pins on Jetson Nano before running the program.

Open a terminal and type the following;

Enable Pin 33 / PWM2

sudo busybox devmem 0x70003248 32 0x46
sudo busybox devmem 0x6000d100 32 0x00

make sure to install busybox library if not installed.
busybox: sudo apt-get install busybox

Running the GPIO configuration program was indeed the solution. I now have pwm working. Thank you.