Pylon Camera on Jetson Error: gst_nvvideoconvert_transform: buffer transform failed

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU) Jetson
• DeepStream Version 6.3
• JetPack Version (valid for Jetson only) JetPack 5.1.1 [L4T 35.3.1]
• TensorRT Version 8.5.2-1+cuda11.4

• Hardware Platform (Jetson / GPU) GPU
• DeepStream Version 6.3
• TensorRT Version 8.5.3-1+cuda11.8
• NVIDIA GPU Driver Version (valid for GPU only) 535.104.12

• Issue Type( questions, new requirements, bugs) bugs
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)

I’ve developed a streaming app using Graph Composer. The pipeline takes input from a Pylon camera, dewarps it and outputs streaming via RTSP. Please see the main (stream.txt) and parameter files (stream.parameters.txt) attached below:
stream.parameters.txt (2.2 KB)
stream.txt (4.6 KB)

For the Pylon camera, I followed the official GitHu instructions to install gst-plugin-pylon and successfully tested live streaming using the command
gst-launch-1.0 pylonsrc ! videoconvert ! autovideosink.
Everything worked well. The Pylon version is pylon_7.2.1 and the .pfs file (Pylon configuration) is attached below:
daA2500-14uc_22594495.txt (3.0 KB)
The dewarper configuration is also attached below:
config_dewarper_fish_dist_correction.txt (2.4 KB)

I tested my app’s pipeline on both x86 and Jetson, and here’s a summary of the results:

  • x86/ hardware encoder: worked
  • x86/ software encoder: worked
  • Jetson(nano)/ software encoder: failed
  • Jetson(AGX)/ software encoder: failed
  • Jetson(AGX)/ hardware encoder: failed

I experimented with both hardware and software encoding by changing the enc-type while keeping other configurations constant. However, I encountered an issue - I’m unable to run the pipeline on Jetson. Please refer to the detailed error message attached below:
log.txt (8.7 KB)

Thank you.

Hi

  1. Can you provide the following output? GST_DEBUG=2,pylon*:6
  2. Does it only happen with the pylonsrc? If you replace it with videotestsrc, does the problem go away?

Thanks for your prompt response.

  1. Please find the output attached below:
    log_gst2pylon6.txt (33.0 KB)
  2. Yes. I tried a USB camera with HW encoder on x86 and Jetson. They both worked with a slightly modified yaml files attached below:
    stream.parameters.txt (2.2 KB)
    stream.txt (4.6 KB)

Thanks. nothing much there, unfortunately. I’m noticing that RGB is negotiated, but nvvidconv doesn’t support RGB (just RGBX), but I’m unsure if it gets processed later. Can you please generate the pipeline diagram?

GST_DEBUG_DUMP_DOT_DIR="/tmp/" deepstream-app -c config.txt

Then, in /tmp/ you’ll see a *.dot file. You can open that file using xdot or convert it to PNG using

dot -Tpng pipeline.dot > pipeline.png

(more details here)

I’m closing this topic due to there is no update from you for a period, assuming this issue was resolved.
If still need the support, please open a new topic. Thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.