Python Bindings for DeepStream not working with RTSP stream

• Hardware Platform (Jetson / GPU) Jetson Nano
• DeepStream Version 6.0
• JetPack Version (valid for Jetson only) 4.6
• TensorRT Version8.0.1.6

• Issue Type( questions, new requirements, bugs) runs well with mp4 files but when I provide RTSP URI it gives an authentication error. Even though same URI works with Deepstream-app if I run it with sample config files. Same URI also works with OpenCV.

I have also tried this but doesn’t work:

• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)

@techguyz any solutions?

Please check if it works in gst-launch-1.0:

$ gst-launch-1.0 uridecodebin uri='rtsp://_IP_ADDRESS_' ! nvoverlaysink

And you may add ' 'before and after the URI for a try.

Yes, using this command RTSP stream works fine.
Screenshot of terminal attached.

Note: I have tried other RTSP links with this python file, they work fine.
This problem occurs when I use a Dahua IMOU IP camera. But this camera’s stream works well with DeepStream-app and GST-lanch so it should work here too.

There’s deepstream-test3 in C. Could you give it a try? Would like to confirm it is not specific to python.

Same problem.

Looks like the URI is not read correctly. In the Now Playing print, it should be:


But it shows only


It should be because & is interpreted as running in background. Please replace & with \& and check if the URI is correctly read.

1 Like

Worked, thanks

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.