Python yolo detect object rect_params always euqal o, but class id and confidence is true

Please provide complete information as applicable to your setup.

• TX2 (Jetson / GPU)
• 5.1
• JetPack Version (valid for Jetson only)
• TensorRT Version
• NVIDIA GPU Driver Version (valid for GPU only)
• Issue Type( questions, new requirements, bugs)
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)


rect_params.left/top/width/height = 0 but confidence and class_id both are true


Could you share which source do you use and fill the system information in the original post?

• TX2 (Jetson / GPU)
• 4.0
• JetPack Version (valid for Jetson only) 4.9.140-tegra
• TensorRT Version5.1.6-1
• NVIDIA GPU Driver Version (valid for GPU only) cuda10.0
• Issue Type( questions, new requirements, bugs) questions

i run, still get the problem,

    print("[{}, {}, {}, {}]".format(int(obj_meta.rect_params.left), int(, int(obj_meta.rect_params.width), int(obj_meta.rect_params.height)))


Do you use JetPack4.0 with CUDA 10.0?
If yes, could you move to latest software since this version is released for a while.

More, which source do you use?
Do you run YOLO with darknet or deepstream object detection sample?


i use JetPack4.0 with CUDA 10.0 and have no other choice.

i used both darknet and resnet of deepstream sample in , and the results are same



Our python sample is for Deepstream 5.0 or newer.
So you may meet some issue when trying to use it on the Deepstream4.0.

To get it work on v4.0 package, please use c++ interface instead.