Python2.7-dev libpython2.7-stdlib version mismatch - JetPack 4.6

Hi. On a fresh install of JetPack 4.6 rev 3 I get an error when installing the Computer Vision components.

I’ve narrowed it down to a version mismatch between python2.7-dev (version 2.7.15~rc1-1) and libpython2.7-stdlib (version 2.7.17-1~18.04ubuntu1.6). The first package is requiring exact version matches so the install fails. OpenCV is asking for python2.7-dev.

The 2.7.15 version comes from the standard bionic main repo, and the 2.7.17 version comes from the bionic-updates main repo. There is a python2.7-dev version 2.7.17 in bionic-updates but for some reason, despite running apt update and seeing the updates repo be loaded, when I apt-cache show python2.7-dev only the older version is there. On my 18.04 workstation I have both versions for both packages so it seems to be something peculiar to JetPack.

Has anyone encountered this problem?

To answer my own question, on a reboot this resolved itself. Why a reboot should matter I’m not sure (not because of apt update because I’d already tried that) but it discovered the newer version of python2.7-dev, installed that, and all other version incompatibility issues went away.

Thanks for the update, not quite sure why a reboot solved the issue, but at least it works now.