PyTorch installation issue for jetson orin nano (torch 2.0.0+nv23.05 and torchvision 0.15.1)

Hello,
I recently got hand on jetson orin nano, and i trying to run Yolov8 using virtual environment , and I follow steps provided here Pytorch compatibility issues (torch 2.0.0+nv23.5 && torchvision 0.15.1) but during installation of torchvision, I encounter error that said :

" running install
checking .pth file support in /home/bizbot/.loca/lib/python3.8/site-packages/home/bizbot/ultralytics/venv/bin/python3 -E -c pass
TEST FAILED: /home/bizbot/.local/lib/python3.8/site-packages/ does NOT support .pth files
error: bad install directory or PYTHONPATH

you are attempting to install a package to a directory that is not on PYTHONPATH and which Python does not read “.pth” files from. The installation directory you specified (via --install-dir, --prefix, or the distutils default setting) was:

/home/bizbot/.local/lib/python3.8/site-packages/

and your PYTHONPATH environment variable currently contains:
’ ’
Is there any location specific that I need to ensure before installing or is there any related issue with the installation ?

I tried reinstalling and change different version of PyTorch but the issue still persist.

Thank in advance.

Hi,

We will give it a check and share more info with you.
Thanks.

1 Like

i found the issue and the solution, during the installation of the torchvision, i installed during in another directory “cd ultralytics/torchvision”, i uninstall the torch and torchvision and reinstall it back without using virtual environment and it install smoothly, reference from this ERROR: torchvision has requirement torch which is incompatible · Issue #40013 · pytorch/pytorch · GitHub and PyTorch for Jetson

Hi,

Good to know it works now!
Thanks for the feedback.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.