QEMU issue when running the l4t-base docker image

I’m building a robot and I want to dockerize my SDK. Im running ubuntu 20.04 as my host operating system on a x86_64 CPU. Since this is an x86_64 CPU, I installed QEMU packages (qemu binfmt-support qemu-user-static) and then wrote my SDK dockerfile and built it. No issues building. While running, I used the following docker run command:

docker run -it --rm --network=host \
        -e DISPLAY=$DISPLAY \
        -e TERM \
        -e QT_X11_NO_MITSHM=1\
        -e XAUTHORITY=/tmp/.docker.xauth \
        -v /tmp/.docker.xauth:/tmp/.docker.xauth \
        -v /tmp/.X11-unix/:/tmp/.X11-unix \
        -v ${WORKSPACE}/:/workspaces/beertender_robot/ \
        -v /usr/bin/qemu-aarch64-static:/usr/bin/qemu-aarch64-static \
        --gpus all \
        --platform linux/aarch64 \
        --runtime nvidia \
        venkisagunner93/sdk-base:latest

I’m able to enter the docker container when I run the above command. But when I execute roscore command. I get the following errors:

root@3po:/# roscore
... logging to /root/.ros/log/6404e6be-a351-11ec-8342-f1965046482c/roslaunch-3po-92.log
Checking log directory for disk usage. This may take a while.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://3po:45325/
ros_comm version 1.14.12


SUMMARY
========

PARAMETERS
 * /rosdistro: melodic
 * /rosversion: 1.14.12

NODES

Unknown host QEMU_IFLA type: 54
Unknown host QEMU_IFLA type: 54
Unknown host QEMU_IFLA type: 54
Unknown host QEMU_IFLA type: 54
Unknown host QEMU_IFLA type: 54
Unknown host QEMU_IFLA type: 54
Unknown host QEMU_IFLA type: 54
Unknown host QEMU_IFLA type: 54
Unknown host QEMU_IFLA type: 54
Unknown host QEMU_IFLA type: 54
Unknown host QEMU_IFLA type: 54
Unknown host QEMU_IFLA type: 54
Unknown host QEMU_IFLA type: 54
Unknown host QEMU_IFLA type: 54
auto-starting new master
process[master]: started with pid [135]
ROS_MASTER_URI=http://3po:11311/

setting /run_id to 6404e6be-a351-11ec-8342-f1965046482c
process[rosout-1]: started with pid [152]
started core service [/rosout]
Unknown host QEMU_IFLA type: 54
Unknown host QEMU_IFLA type: 54
Unknown host QEMU_IFLA type: 54
Unknown host QEMU_IFLA type: 54

Then I went ahead and removed --net=host from my docker run command and the error went away. The problem here is, if I take out host network, I won’t be able to listen to the topics running in the robot. Any thoughts on how to fix this problem is much appreciated. Thanks!

If you want to reproduce the issue here is the docker image: docker pull venkisagunner93/sdk-base:latest

Hi,

Could you check the below document to see if you have set up all the requirements first?

Thanks.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.