qnx TK1: how to mount root directory as read/write


I flashed qnx (vibrate-qnx) into TK1 board.

When I remote log in TK1 board using the command: “ssh root@ipofTK1”. I found I could not create file inside the directories: “/”, “/tmp” and so on. I only have the write access in the directory “/root”.

I tried remount as per instruction of qnx and it does not work either.

mount -uw /

mount: Can’t remount / (type default)
mount: Possible reason: Invalid argument

Anyone has ideas?


I have no experience with QNX, but I cannot find lower-case “-u” as a valid option. There is an upper case “-U” to specify a user ID (in the case of root partition you’d want UID 0). Then the “-w” would remount as writable. So try this instead, with “-U” upper-case:

mount -U 0 -w /