Qt-default version issue on migration from RPi4 to NVIDIA Jetson Nano

Having an issue on migrating a Qt project from RaspberryPi 4 to NVIDIA Jetson Nano . We wanted to migrate our project to Jetson Nano to improve image processing performance.

The qt dependency of our project is >= 5.11 . But Jetson Nano uses Ubuntu 18.04.4 and it has qt5-default package pre-installed in it (in my understanding some system files use it). And this qt5-default packages version is 5.9.5 .

I tried to downgrade my qt dependency, but every change made lead to harder to fix issue.

I tried to upgrade default qt5 version but couldn’t find any similar guidance. The guides/questions already exists are about x86 etc. environment. Couldn’t find any ARM based solution. The qt downloads doesn’t give any buildable for ARM env (or I can’t find them). The official documents only talks about cross-compiling.

What should I do to overcome this issue? Thanks in advance.I’m not an expert of these topics.

We have tried

It is 5.9. You may download a newer version and try.

I came across this post.
http://master.qt.io/archive/ in this download archive mentioned in related answer, I tried few downloads but they all look like they’re not fitted for arm-based devices. Am I skipping something.
qt-everywhere-… file has gnuwin32 in it.

some more url’s
it also should be possible to build qt from sources;
Otherwise it might be possible to cross compile a project from x86_64 so that it can e executed on arm

couldn’t solve my problem exactly, but some milestone advised by someone here, if anyone interested in topic.