QT Version

My ubuntu version is 18.04
My gcc version : gcc (Ubuntu/Linaro 7.5.0-3ubuntu1~18.04) 7.5.0
QMake version 3.1
Currently I am using Qt version 5.9.5 in linux.
Jetpack Version: 4.6-b199

Which max QT version I can use in present case?