QT5 packages to reinstall


Yesterday, I was having difficulty installing ROS on my TX2. I perused the forums and followed some bad advice. Namely, the following command: apt-get purge ‘.qt5.

Every thing seemed fine, but when I booted this morning, the UI was messed up. No unity bar, window bars, top bars, etc.

I’m trying to undo the damage I did. Can someone point toward packages I might install to fix this? I naively tried apt-get install ‘.qt5.’, but that didn’t work. It said I had broken packages.


I don’t know about the Qt packages, but for the ones specific to the Jetson see if this shows ok:

sha1sum -c /etc/nv_tegra_release

…if those are not in place, then those need to be corrected before anything else.

All show ‘ok’.

I cannot check on a TX2, but looking at a TX1, you may try :

sudo apt-get install appmenu-qt5 libaccounts-qt5-1 libdbusmenu-qt5

Thank you. I tried your command and still have the same problem. I’m considering just starting from scratch if I can’t figure it out soon.

Nuked the system and started from scratch. Thank you everyone for your help.