Qtmux error "Buffer has no PTS"

I’m adding a small piece of pipeline to record the input. I have tried two solutions:

  1. Add queue, qtmux, filesink into rtsp_tee, before decoder.
  2. Add encoder, h264parse, qtmux, filesink after multi_src_bin (as below picture, new elements are in red pencil).

But both solutions give error when starts playing.

ERROR from record_muxer: Could not multiplex stream.
Debug info: gstqtmux.c(4561): gst_qt_mux_add_buffer (): 
Buffer has no PTS.

Do you have any idea about how to resolve this error? Thank you.

• Hardware Platform : JetsonNano
• DeepStream Version : 5.0 DP
• JetPack Version (valid for Jetson only) : 32.4.2-20200408182156
• TensorRT Version : 7.1.0-1+cuda10.2

Since you have nvstreammux in the piepline, you would need to link either nvmultistreamtiler or nvstreamdemux before encoder.

Thank you for your reply. I tried to add nvstreamdemux right before encoder, but it causes Segmentation Fault when linking nvstreamdemux with encoder.

Let me try to move the record_bin, to ahead of nvstreammux.

Hi all,
Actually, the reason is my input RTSP stream doesn’t contain PTS information.
When I try with another RTSP stream with PTS information, it works. Thank you.

1 Like