Quad buffer Stereo in OpenGL

I upgraded to Windows 10 with latest Nvidia 3D vision drivers. My OpenGL quad buffer stereo OpenGL application stopped working. The screen shows two views but the shutter glasses never comes on. Does anyone know of proper settings in OpenGL for stereo to work in Windows 10? This same application used to work fine on Windows 7. Thanks for any insight on stereo to work with latest software and OpenGL, version 4.5.

I am curious to see if you get this working. I am still at windows 7 and have QB OpenGL stereo working for ArcMap, and don’t want to get stuck if I upgrade. Best of luck.
Perhaps you should reinstall your drivers, and double check that your video card is fully supported for windows 10 and DirectX 11.
G.

So far I haven’t gotten any response from Nvida or anyone else. I reinstalled the driver… the sample MPO files in DirectX work fine, so I know the card and glasses do function OK. It is only the OpenGL application I have issue with. Quite frustrating as it is holding up my research. Please let me know if you find any information on making OpenGL stereo work in Windows 10. Thank you.

StereoGraphics,

Thanks for reporting this issue. Could you specify your detailed configuration and reproduce steps? such as GPU model, Nvidia Driver version, Windows 10 build number and what OpenGL application you are using.

Following is my system configuration:

DELL M6700 with builtin stereo capable screen along with Nvidia 3D vision pro active shutter glasses.
OS: Window 10 Education. Version 1607 (OS Build 14393.693), a 64-bit OS for x64 based processor.
Processor: Intel i7-3940XM 3.2 GHz
RAM: 16 GB
Nvida Driver: 362.56 (I got same results with latest R375 U4 (376.62)). I switched to 362.56 because that is what Nvidia customer support folks recommended for stereo. I did clean install of drivers.
GPU: K5000M
Applications: C:\Program Files (x86)\NVIDIA Corporation\3D Vision\NvStereoUtilityOGL.exe

The above OpenGL application comes with the driver and does not turn on the active shutter glasses. The 3D video games screenshots that comes with the driver (can’t locate were both files are installed) work fine. Additionally, I received a StereoSample.zip file with source from Nvidia that I build on Windows 7 and it worked but on Windows 10 it did not.

I used Visual Studios 2015 to build the source.

Reproduce steps will following:

  1. In Nvidia Control Panel:
    a) Display -> Change resolution -> Refresh rate set to 120Hz
    b) Stereoscopic 3D -> Set up stereoscopic 3D -> Enable stereoscopic 3D is checked
    c) Stereoscopic 3D -> Set up stereoscopic 3D -> Run Setup Wizard clicked and made sure stereo is work. It was, both screen and shutter glass worked for 3D video games sample screen shots.

  2. Executed C:\Program Files (x86)\NVIDIA Corporation\3D Vision\NvStereoUtilityOGL.exe. This showed either two views on the screen but the active shutter glasses never came on.

  3. Attempted to run executable from StereoSample.zip (an sample received from Nvidia) with same results in step 2.

Please let me know if I can provide more detail. Thanks for any suggestions or samples to try out.

Hi StereoGraphics,

Thanks for your details
Could you also try to manually turn on Stereo with the following steps in Nvidia Control Panel?

“NVIDIA Control Panel”-> “Manage 3D settings”-> “Stereo - Enable” : set to “On” +
“NVIDIA Control Panel”-> “Manage 3D settings”-> “Stereo - Display mode” : set to “Generic active stereo (with NVIDIA 3DVision)” .

Thanks for getting back to me. I have confirmed that I have manual setting you mentioned in your post. I am still getting same behavior that is two images on the screen but active shutter glasses not turning on.

May I ask if NvStereoUtilityOGL.exe work OK on your end and if it does what settings you system has? Thanks.

I work with a Quadro 5000 card. The settings I need to activate the emitter and the glasses are as follows:

Ensure the refresh rate of the 3D monitor is set to 120 Hz, and the 3D monitor is the primary if using multiple monitors.

“NVIDIA Control Panel”-> “Manage 3D settings”-> “Enable overlay” = “On”.
“NVIDIA Control Panel”-> “Manage 3D settings”-> “Stereo - Display Mode” = "On-board DIN Connector (with NVIDIA 3D Vision).
“NVIDIA Control Panel”-> “Manage 3D settings”-> “Stereo - Enable” : set to “On”.

This may help as if NVIDIA 3D Vision does not activate the emitter, the application can’t use the 3D Vision software to sync the hardware being used.

That’s my best guess, good luck.
G.

One more thing that I noticed. Is your video card on a laptop? If yes, then I would suggest reinstalling the drivers and making sure a 3D Vision emitter is plugged in before & during the install. That may unlock the Stereo display mode I listed in the last reply.

Thanks for the info… The video card is on a laptop. K5000M, which is what I am using, is mobile version of K5000.

There is no external emitter. All the hardware is built into the laptop, Dell M6700, including emitter. The shutter glasses sync and work fine with the sample splash screens that came with the driver, but I am unable to get the glasses to work with NvStereoUtilityOGL.exe or my own OpenGL program that uses quad buffers. Even though the glasses remain synced, the don’t turn on when an OpenGL quad buffer app runs.

I will give your suggestion a try and update. Thank you.

If you have an external emitter handy, I would try it for during the reinstall. I have tried the same thing with a laptop, and had similar issues with OGL Quad buffering. Unfortunately, I’m not a programmer, so I don’t know the details of why it works, only have gotten lucky through trial and error.

For me it’s even worse.
I have some Quadro P5000.
On Computers running Windows7, Stereo QuadBuffer is working fine.
I’ve just installed Win10 on another computer, and the Quadbuffer stereo is not working at all !!!
I’ve even tried the Stereo 3D test in the driver and even if it runs at 120Hz, there is only 1 image displayed.
Is Quadbuffer stereo completely broken with Win10 ?..
I’ve tried many things in quadbuffer stereo so far :

Quadro FX5800, Win 7, OK
Quadro P5000, Win 7, OK

But :
Quadro FX5800, Win 10, not working at all
Quadro P5000, Win 10, not working at all

Seems completely related to Win10.
Is it supposed to work ? Or do we need a driver update for Win10 to finally have Quadbuffer stereo with Quadros ?

I noticed a few settings must be ensured for OpenGL Quad Buffer applications, which are;

  1. On Windows 10, make sure “3D display mode” is set to “On” in Windows settings: Settings --> Display --> Advanced

  2. Make sure OpenGL is turned on: --> Manage 3D Settings --> Global Presets --> OpenGL rendering GPU --> <choose your graphics cards - for my laptop it is Quadro K5000M>

  3. Make sure Stereo is turned on: --> Manage 3D Settings --> Global Presets --> Stereo - Enabled >

  4. I also rollback my Nvidia driver to Drive Date: 12/29/2016 Version 21.21.13.7654

Additionally, I had to sync my goggles to my laptop’s emitter. After all this, I was able to run my old OpenGL Quad buffer application in stereo on Windows 10. I am not changing my setting as it works now!

Hope this helps… Please let us know if above steps work for you? Thank you

Thanks a lot for your help.

I’ve already set the 2/ and 3/ but I didn’t know about the 1/
So I’ll give it a try tomorrow and I’ll let you know !!
I don’t think I can do the 4/ because the P5000 is very recent and the drivers are not very old.

Have a nice day !

It works !!!
Actually it is even possible that it worked from the beginning.
The thing is that one must absolutely not rely on the NVidia 3D test in the driver tab.
Because this test is not working in Windows10 !!!
I gave it too much credit because it worked just fine in Windows7, so I installed Win10 and used it as a 3D QuadBuffer test …
So I tried my 3D engine this morning and realized that the QuadBuffer stereo was working just fine.

Thanks a lot StereoGraphics for your much appreciated advices.
And if my experience could be of any use for other people, keep in mind : “Don’t trust NVidia 3D test”.

I have windows 7, Quadro K4000, how to make it work???
It is not working now. The green light on IR emitter is bright.