Quadro 2000 Under Ubuntu, not output except on DVI port through DVI->VGA adapter.

The group of >90 web developers that I support use Dell Precision Workstations with Nvidia cards and dual monitors for development stations. The first 90 or so machines we purchased have Quadro NVS 295 cards (dual Display Ports with DP -> DVI adapters). We install Ubuntu (currently using 12.04 LTS with the nvidia drivers from “Additional Drivers”, the Ubuntu recommended version). This configuration has worked very well for us and we are very happy with the configuration.

In the last two of these machines that we received from Dell, they substituted the Quadro 2000 card (dual display ports + a DVI port), I assume because they had none of the Quadro NVS 295 in stock, because we didn’t pay for them. Other than that, the machines are identical to the previous 90+ that we purchased. This configuration has caused me no end of headaches since the day they came in.

Initially, the system would just hang when attempting the boot the installation media. Some Google searches found a work-around. It will successfully boot and install if I use the supplied DVIa->VGA adapter, and boot the machine while attached to the monitor via analog rather than digitally. After installing the OS, and the Nvidia driver, I was able to reattach the monitors digitally via the two display ports, and deploy the machines to my customers, and they were successfully used for about 3 months.

Last week I had to re-install the OS on one of the machines, and encountered more problems. This time, after installation of the OS, and driver by booting with the monitor attached via the DVIa->VGA adapter, then attempting to reattach digitally to the monitors, No digital output is appearing on the monitors. I’ve tried both display ports, and attaching the monitor via DVI to the monitor. The only successfull attachment is via the DVI->VGA converter. None of the other ports even seem to be turned on. I’ve tried rebooting the machine with two monitors attached to the Display Ports->DVI adapters, I’ve tried rebooting the machine with a single monitor, attached to each display port, and the DVI port (via DVI cable to the monitor). I never see even the system boot splash screen, or the POST output. Just a black screen. If I, after the machine has completely booted, attach the VGA monitor through the DVIa->VGA adapter, I see the text console, and can login (Xwindows didn’t start).

I’ve tried the Ubuntu 12.04 open source driver for Nvidia cards (works fine), the Nvidia driver which Ubuntu labels “Version Current [Recommended]” (exhibits the above symptoms), the Nvidia driver which Ubuntu labels “post release updates (version current updates)” (exhibits the above symptoms), the Nvidia driver which Ubuntu labels “version experimental-304” (exhibits the above symptoms), the Nvidia driver which Ubuntu labels “version experimental-310” (exhibits the above symptoms), and the Nvidia driver directly from Nvidia’s apt repository (exhibits the above symptoms).

I’ve also tried swapping the cards from one machine to another, thinking something had gone wrong with the hardware. Both cards work the same way in both machines.

I’ve found that if I attach using the VGA Adapter method, then attach a 2nd monitor to any display port, I can use the Nvidia X Server Settings program to go through a laborious manual method of activating the other ports, I can get one display port, and the DVI port to work, all in digital mode to the DVI ports of the monitors. This is a less-than-optimal work-around, but I can at least use these two workstations again.

Any thoughts?

I read the “If you have a problem, PLEASE read this first” but saw no obvous (to me) place to run this diagnostic. Let me know if you have any suggestion of where I should run it.

Thanks in advance,

Ron

Can you connect to these machines via SSH? If you can boot one of the machines in one of the problematic configurations, log in via SSH and run nvidia-bug-report.sh after trying to start X, that would be ideal.