Quadro K1100M: X Server session crash for

Hi, when my laptop resumes after suspend, the desktop session crashes and a new one is started. So I lose each time all open applications and unsaved data!
The expected behavior would be obviously to restore the suspended session.

I had a look through log files and found that Xorg.0.log ends with the following error lines:

[ 6004.019] (II) NVIDIA(0): Setting mode "NULL"
[ 6004.026] (EE) modeset(G0): failed to set mode: No space left on device
[ 6004.026] (EE)
Fatal server error:
[ 6004.026] (EE) EnterVT failed for gpu screen 0
[ 6004.027] (EE)
[ 6004.027] (EE)
Please consult the The X.Org Foundation support
  at http://wiki.x.org
 for help.
[ 6004.027] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 6004.027] (EE)
[ 6004.065] (EE) Server terminated with error (1). Closing log file

I’m using:

Ubuntu 18.04.1 LTS
Linux kernel: 4.15.0-38-generic
xserver-xorg: 1:7.7+19ubuntu7.1
nvidia-driver-390: 390.77-0ubuntu0.18.04.1
nvidia-bug-report.log.gz (139 KB)

I forgot to mention the card is a Quadro K1100M on a Dell Precision M4800

Your bios is rather old, please upgrade and check if that resolves the issue.

Hi, I followed your advice and did upgrade my laptop’s bios. Everything was looking fine for a while, but then it happened again. The same message was shown in the file Xorg.0.log:

(EE) modeset(G0): failed to set mode: No space left on device

Many thanks.

Is this consistently happening on every suspend/resume cycle or sporadic? Is this reproducible when switched to intel only (sudo prime-select intel)?

With nvidia enabled, the longer it sleeps the more likely it crashes. If it is suspended for at least a hour or so, then it is almost certain it will crash.

I also tried a couple of times with intel selected, and it didn’t crash even after a few hours sleeping.

That sounds rather like a hardware failure. Should be consistent no matter how long the system was suspended. You could check if modifying /lib/modprobe.d/nvidia-kms.conf changing
and running
sudo update-initramfs -u
works around it.

I can’t find any nvidia-kms.conf file in that directory. I only have a file named nvidia-graphics-drivers.conf with the following content:

blacklist nouveau
blacklist lbm-nouveau
alias nouveau off
alias lbm-nouveau off

Should I modify that one, or create a new one with the filename you specified?

Looks like it’s not set anyway on your system.