Quadro K2200 Driving Four DP Displays in Ubuntu 18.04

I am trying to get a Quadro K2200 card to drive four displays. Would you please help me understand the problems I observe. The workstation is an HP Z840 with four Dell U2415 displays in a daisychain configuration, where the first three have MST 1.2 enabled and the last monitor in the chain does not.

I tried installing Ubuntu 18.04.3 server, desktop and kubuntu with various levels of success. I succeeded in getting the four displays to work but only intermittently; some displays became black after a reboot, started flickering, or would freeze soon at login.

Here are log files from an attempt to install a “normal” installation of Kubuntu 18.04.3 from DVD, with the “install third-party software…” option selected. This installed nvidia driver 390. After rebooting, the displays were black.

Would you please suggest troubleshooting steps.

nvidia-smi.log (1.36 KB)
ubuntu-drivers-devices.log (392 Bytes)
nvidia-bug-report.log.gz (558 KB)

DP daisy-chaining is a pain with the linux driver.
Do you get different results when upgrading the driver to v430/435?

I tried the following combinations:

  • 390 x Kubuntu The driver was loaded during DVD install
  • {430,435} x {Ubuntu Server 18.04.3 + Kubuntu, Ubuntu Server 18.04.3 + MATE} This was a console install where the nvidia drivers were manually installed from PPA.
  • {nouveau} x {Ubuntu Desktop DVD + Kubuntu} This was a DVD install.
  • My first attempt used an HDMI monitor with dual DP daisychained monitors. I noticed black screen flickering, but it worked OK so I proceeded with quad DP daisychained monitors.

    The Nouveau+Desktop install worked on all four monitors when first booted. After the first reboot, the keyboard and mouse worked but I could not click any options or enter a password at the login screen. Also, only two monitors appeared.

    A similar instability was observed in the Server+Kubuntu install using 430 and 435 drivers: sometimes all four worked initially but later they failed.

    Sometimes when I entered a console, all 4 monitors showed text even though the desktop only worked on 2 out of 4 displays.

    There are many log files spread across different locations, so it is difficult to understand what is happening, but I notice the following messages in some of the logs. Do any of these messages suggest a cause:

    • sddm directory not found

    • nvidia config directory has a file /usr/share/X11/xorg.conf.d/10-amdgpu.conf (this is an HP z840 which does not have an onboard video)

    • nvidia settings -q all: unable to init server: could not connect: connection refused

    I think that quad DP daisychained monitors is an approved configuration by both HP and Nvidia. Do you think there is any chance in getting 4 monitors to work using K2200? I can get this configuration to work in Windows 10 but it would be a shame to put windows on this workstation.

    Thank you,

    The relevant error is in the xorg log:

    [    28.085] (WW) NVIDIA(GPU-0): Timed out waiting for DisplayPort device detection to
    [    28.085] (WW) NVIDIA(GPU-0):     complete.

    It seems to me that the linux diver is much more sensitive to delays on DP connections than the windows driver, so daisy-chaining rarely ever works flawless, depending also on monitor model.

    Addendum: you might try if the kernel parameter nvidia-drm.modeset=1 changes anything.